Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed the ODT to LaTex converter for OpenOffice under Ubuntu 9.04 because I wanted to convert my basic document template and even though it found the proper Sun JRE (Version is 1.6.0_14, ddisplayed under Tools -> Options -> OpenOffice.org / Java) and the OO Java package has been installed it still gives me this error message:

OpenOffice.org requires a Java runtime einvornment (JRE) to perform this task. The selected JRE is defective....

I ran out of ideas on how to fix this.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Try the solutions mentioned in this thread:

  • Close OOo and delete the ~/.openoffice.org/3/user/config/javasettings_Linux_x86.xml file
  • If that didn't work, rename your OOo user profile (~/.openoffice.org)

If these don't work, look through the thread for a number of other workarounds. This bug report also seems relevant to your issue: Stream of JRE errors when going to "Macros" tab in frame properties

share|improve this answer
    
Thanks a lot, deleting the file worked fine! –  Daff Aug 26 '09 at 7:21
add comment

Does it require "a" JRE or "that" JRE? Cus couldn't you just install another Java environment and it'll work?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.