Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to add a local printer in Windows 7 station. I receive an 0x000006be error. This is the first time I am installing this printer driver on this station.

Please advice.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You likely have driver corruption issue. You can try to remove all printer driver and reinstall them. A similar thread exists over technet: http://social.technet.microsoft.com/Forums/en/itprovistaprinting/thread/3e47b7b6-00a3-47e1-9e28-e615fbff5f87 but that particular thread is for windows vista so the answer may or may not work.

Since it worked, here's the text from the linked document (Originally by Arthur Xie, a Microsoft Employee):

Remove a printer

  1. Click the "Start" button, type PRINTER in the search box and press Enter.
  2. Find the icons of installed printers, and delete them.
  3. Right-click on the blank part of the window, and choose "Run as administrator"->"Server Properties".
  4. On the Drivers tab, select the listed printers and click the Remove button. Please then select Remove driver and driver package.
  5. Open Start menu, input APPWIZ.CPL in the Search box and press ENTER to launch "Programs and Features".
  6. Try to remove all related printer software.

If the issue is not resolved, I suggest that you clear the printing sub system.

Step 1

Start Windows Explorer, and then rename all files and folders in the following two folders:

c:\windows\system32\spool\drivers\w32x86

To rename a file, we can right click the file and select Rename.

Step 2

  1. Click Start, type REGEDIT in the Start Search Bar, and then press ENTER.
  2. Navigate to and then click the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environment\Windows NT x86

View the list of subkeys. There should be only the following subkeys:

Drivers
Print Processors

If there are any keys other than those listed above, follow these steps:

a. On the File menu, click Export. b. In the File Name box, type a descriptive name for this key -- for example, type WindowsNTx86regkey -- and then click Save to save it to your local Desktop.

We can use this backup of the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environment\Windows NT x86 registry key to restore the key if you experience any problems after you complete this procedure.

c. Delete all keys other than Drivers and Print Processors.

Step 3

Navigate to and click the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors registry key. View the list of subkeys. There should be only the following subkeys:

 
BJ Language Monitor
Local Port
Microsoft Document Imaging Writer Monitor
Microsoft Shared Fax Monitor
Standard TCP/IP Port
USB Monitor
WSD Port

If there are any keys other than those listed in above, follow these steps to delete them:

a. On the File menu, click Export. b. In the File Name box, type a descriptive name for this key -- for example, type Monitorsregkey -- and then click Save to save it to your local Desktop.

We can use this backup of the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors registry key to restore the key if you experience any problems after you complete this procedure.

c. Delete all keys other than the 5 listed above.

Step 4. Disconnect the printer cable from the computer, and then restart the computer.

Step 5. Reconnect the printer cable to the computer, install the printer according to the manufacturer's installation instructions, and then check if the issue persists.

share|improve this answer
1  
Thanks, I followed the instructions and it works. –  Dean Jun 14 '11 at 12:16

Restart the computer and the printer will be installed and ready to go.

share|improve this answer
    
Any particular reason that this will work? Any reference/documentation that you can provide that explains your answer? –  MaQleod Oct 19 '12 at 21:08
    
Any particular reason why you are asking? It works! And that's why should be the accepted answer. –  Antony Hatchkins May 19 at 17:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.