Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a local workgroup network.

It has one ubuntu 10 LTS machine, two XP boxes and a Windows 7.

I everything works great eccept for the Widnows 7 box. I can see it and access it from the other boxes, including the ubuntu one.

From the W7 i can access the XP's and I can see the ubuntu machine, but if i try to Map Network Drive it fails to authenticate the user (i can use that user/psw from a different box).

[EDIT] Windows 7 Home Premium seems to be missing the Local Security Policy editor

share|improve this question
    
What version of samba? –  uSlackr Jun 14 '11 at 13:32
    
@uSlackr: i commanded sudo apt-get install samba smbfs which I assumed would install the latest version... –  goliatone Jun 14 '11 at 14:53

3 Answers 3

Make sure Homegroup is turned off on the Win7 machine. Homegroup only really works in pure Win7/Homegroup environments (or, at the very least, when networking only Win7 machines is what matters), and can cause problems in mixed environments.

Second, make sure you've installed Samba server (not just the client), and have set up a Samba user for the Windows machines to use. The Samba user is different from the computer user and only a Samba user will be allowed to access the shares.

If you still have trouble, you might want to check out a Google search on the topic, as Win7 doesn't always like to play well with Samba.

share|improve this answer
    
I'm thinking that samba works ok since I had no troubles when the network was only ubuntu+XP, the issue was when I added the W7 box so I believe it is a specific issue with that OS version. –  goliatone Jun 14 '11 at 14:56

There is a problem with this depending on the version and settings of Samba. Windows 7 defaults to NTLM responses only. You can change it to send LM and NTLM. Details here

There should be a corresponding for the samba server side, but I cannot find it off-hand. But the above should cure your ills.

share|improve this answer
    
Thanks for the link, I had found that thread on my google search, but had issues following the steps (can't find the Local Security Policy tool –  goliatone Jun 14 '11 at 15:02
    
@goliatone - Make sure you have Advanced File Sharing turned on, then. It's likely that information is hiding if you only have basic sharing on. –  Shauna Jun 14 '11 at 15:04
    
try running gpedit.msc from the start menu search box –  uSlackr Jun 14 '11 at 15:08
up vote 1 down vote accepted

ok, i have it working now.

I had previously changed the settings under config advanced sharing (translated from spanish, so not sure) I activated network detection, shared use of documents and printers, deactivated password protected shared use, and changed 128-bit encryption to 40/56 bits.

Now, before I had Windows administering the connections, so I changed that to use user and password to connect instead and works...

Sorry if the option names don't correlate literally to the english names, I have the OS in Spanish. Hard to translate.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.