Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed VirtualBox on a Macbook with Mac OS 10.6 and it's running great. Inside the VirtualBox I'm running Ubuntu 10.04. Really impressive setup and install process.

However, there's one problem, which is that Ubuntu has no network connection. And I'm a total newbie to networking.

Could anyone suggest where to start?

Infinite gratitude will be yours :)

share|improve this question
    
Please help us helping you by showing us your VirtualBox settings, especially those of your virtual machine under "Networking" settings. Also, show us the output of ifconfig when run in the Terminal in Ubuntu. –  slhck Jun 14 '11 at 11:33

1 Answer 1

Networking should already be set up as a NAT:

enter image description here

Another choice is setting it up as a Bridged Network, in my screenshot it's pointing to my ethernet, but there should be an interface for your wireless (wlan0 perhaps) this will make your VM act as if it were a computer in your physical network and get local IP Address that will allow you to browse to it from other devices in the network:

enter image description here

share|improve this answer
    
To add to Sandeep's answer, make sure Ubuntu is actually seeing a network card. ifconfig can give you that answer. If I remember right, VitualBox's tools might have something for fixing cases when the guest OS doesn't recognize the host network card. –  Shauna Jun 14 '11 at 12:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.