Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed Mythbuntu on my computer but it won't boot anymore, the only thing it does is write:

Grub stage 1.5

Error 15

file not found...

When I load it with a live-cd and search, there is no file /boot/grub/ and when I log into the grub console (sudo grub) and try to fix it :

root (hd0,5) setup (hd0)

It tells me that the files

/boot/grub/ /grub/

are not found. (Ps: partition 6 is the good one but I've tryed them all up and none is working)

Thank you.

share|improve this question
    
Could you add details of the system's drives+partitions (i.e. the output of fdisk -l)? As you didn't mention them I'm assuming there is no RAID or LVM setup on your install. Could it be that you are hitting some sort of limit as to where on the drive the boot partition can be (lilo used to have a lot of problems with large drives because of that sort of thing) in which case you might need to have a small /boot partition somewhere early on the disk if you don't already have it separate from /. –  David Spillett Aug 25 '09 at 22:56

3 Answers 3

Try with the command:

find /boot/grub/stage1

to see if you can find it and use

root (hd?,?) setup (hd?)

where ? is the data that find command retrieve

If it doesn´t works, you can try with your installation cd, open a shell a use:

linux rescue

and introduce the following commands

chroot /mnt/sysimage
grub-install --recheck /dev/hda
exit
exit
share|improve this answer
    
find /boot/grub/stage1 display Error 15 file not found –  Drahakar Aug 25 '09 at 23:54
    
/mtn/sysimage doesn't exist :( –  Drahakar Aug 26 '09 at 21:09
    
If you don´t want to lose a lot of time, try to reinstall everything. It may work :) –  Onir Aug 26 '09 at 23:01

Make sure you are setting the correct partition for grub s config file.

I had this error once and ended up being that I had set 5 instead of 6 and I couldn't spot the error right away because of course, its sda6, so its (hd1,6)!. As I had being making a lot of other config edits (it was an Arch install), I missed it.

I should have put (hd1,5)

share|improve this answer
    
well I did try hdo0,x (from x=0 to x=9) (I was also pretty piss off...) –  Drahakar Aug 26 '09 at 0:51
up vote 0 down vote accepted

It seems like I can't make it work, so I've installed an other distro and now it works, thanks for all you help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.