Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running DropBox on a few computers, but one of those computers (a Mac) I have multiple accounts on. One account is for general usage and the other account is for software development. I'd like both computer accounts to access the same DropBox account, but ideally using the same folder on the computer so that one account isn't downloading the same files the other account just downloaded.

I tried putting my DropBox folder in /Users/Shared/DropBox but I end up with permission issues since files default to being owned by one account and not the other.

I suspect I'd need to create a group which both users are a member of and then make sure files are always group readable/writeable. Does anybody have better suggestions?

share|improve this question

3 Answers 3

Give both users the same permissions for the folder using chmod

If you want to give permissions to all users to read, write, execute put in sudo chmod -R a+rwx [folder name] in the Terminal.

UPDATE:

The above command only does it for the directory as it is, any new files/directories created will not inherit the permissions.

Put in chmod -R g+s [folder name] and this will set the permissions recursively and any future files and folders will have the correct permissions.

Run both commands to achieve sharing between the users of the DropBox folder.

share|improve this answer
    
The problem is I need to do that for every new file/directory I create. I'm looking for a way where I don't have to do that. I love how transparent DropBox is and want to keep it that way. –  Brian Kelly Jun 14 '11 at 14:32
    
You have one DropBox folder right? So set the permissions for that DropBox folder and add the -R flag to the command to make it recursive for the folders and files inside the folder. –  paradd0x Jun 14 '11 at 14:35
1  
Using the group sticky bit will do what you want. chmod -R g+s Dropbox –  Chris Nava Jun 14 '11 at 14:57
    
I will try this when I get back to the Mac in question. Thanks, guys. –  Brian Kelly Jun 14 '11 at 15:09
    
The sticky bit solution doesn't seem to work. I set the sticky bit, create a file and it's still only user writable. –  Brian Kelly Jun 16 '11 at 2:17
  1. First, move dropbox and clear out the /Users/Shared/DropBox/ folder (to simplify things, otherwise it's a good bit of manual work to fix all the permissions).
  2. Create a new group, call it DropBox
  3. Add both of your user accounts to the group DropBox
  4. Create the shared folder again if it doesn't already exist (mkdir /Users/Shared/DropBox)
  5. Set permissions on the folder:
    chown root:DropBox /Users/Shared/Dropbox/ chmod 0770 /Users/Shared/DropBox/ chmod g+s /Users/Shared/DropBox/
  6. Set Dropbox to point to that folder
share|improve this answer

Note: I know nothing about Mac shares... These instructions are for *nix shared folders. They should work on a Mac. YMMV ;-)

First, you need to set the group sticky bit. chmod -R g+s Dropbox This will cause all new files/folders created in Dropbox to have the same group as the Dropbox folder.

Then you will need to change your umask to umask 002 if it isn't already. This will make sure all newly created files/folders are always writable to the group.

For files already in the Dropbox folder run chgrp -R {groupname} Dropbox to reset their group. Fill in whatever group name the user's all have in common.

[Edit] Here's an article on sticky bit that mentions setting up a "drop-box" folder for sharing. http://www.dba-oracle.com/linux/sticky_bit.htm

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.