Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Maybe a simple question but I'm a little frustrated. I must have changed a setting in Textmate but can't seem to figure out what I have done. I can place the cursor in any place on a line even after a line break (can see the line break by showing invisibles). How do I set it so that it always goes back to end of line based upon new line character rather than anyplace in the line (including after the line break)?

For example, using the down arrow key will just place me into the line at textmate of where cursor was rather than at end of the current line.

thx

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

You've probably enabled Freehand Editing without knowing. Go to Edit - Mode - Freehanded Editing and turn it off.

enter image description here

See the Working With Text part of the TextMate manual for more info.


By the way: You can get a similar behavior from holding down alt and then clicking, which temporarily turns on the column-based editing mode. You can then click anywhere inside the document and the cursor will go there. Release alt and it is turned off again. It's actually a neat feature.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.