Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 on a computer with an Audigy Platinum eX sound card connected to a surround receiver via optical cabling.

Sound works fine when listening to non-surround audio sources, such as windows sounds or MP3. However, when I view a DVD in Media Center and the SPDIF passthrough kicks in, I can only hear an awful noise instead of the movie soundtrack.

Also, the receiver does not show the Dolby Digital or DTS symbol, but stays at Dolby Prologic, so it seems it doesn't identify the sound encoding properly.

I could switch off SPDIF passthrough and use the sound card's decoder instead, but that's not an option for me since it would create more problems with regular MP3 playback via additional Stereo Receiver which is also connected to the same sound card.

I've tried both the default Audigy drivers that come with Windows 7 and the latest drivers from the Soundblaster website, but the problem remains unchanged. Also, I have ensured that the receiver's Dolby Digital decoder is not broken by successfully connecting it to my PS3 to view a Dolby Digital DVD. Besides, SPDIF passthrough was working fine in Vista before I upgraded to Windows 7.

Is there anything else I could try?

share|improve this question
    
I am having the same problem with my Creative Audigy 2 Platinum. When I play the Dolby Digital test from the control panel sound settings, the receiver shows a Dolby Digital Signal. Also PowerDvd is able to output Dolby Digital to my receiver. However, I am unable to get Media Center to output Dolby Digital. It seems to me that Media Center is missing the setting for SPDIF passthrough of Dolby Digital and DTS signals. PowerDVD and Windows 7 Control Panel can both do it. –  user19260 Nov 25 '09 at 18:31
    
So you installed powerdvd on windows 7 and now SPDIF passthrough works fine? –  Adrian Grigore Dec 31 '09 at 12:02

6 Answers 6

Sounds suspiciously like a driver issue, unfortunately!

I use the built in optical-out on my HTPC, which is a Realtek ALC889A chipset, without incident, using all default Windows 7 drivers and Windows 7 Media Center -- it correctly passes the Dolby Digital to the receiver via optical out.

It's a shame how Creative has dropped the ball so badly on the sound card front, and since embedded sound chips are now pretty good, there's almost no reason to ever use PCI sound cards any more.

share|improve this answer
2  
Agreed. Creative has tanked. My last card from them was an X-Fi Platinum something or other and it was a POS. –  raven Oct 3 '09 at 0:55
    
I was afraid this would be the answer, because I really liked my Audigy platinum while it was still properly supported. No sense in ignoring the truth though... –  Adrian Grigore Nov 12 '09 at 14:44

Have you tested the SPDIF connection in the Sound Settings?

  • Right click the speaker icon in the system tray
  • Select "Playback Devices"
  • Select your SPDIF device and click the "Properties" button
  • Click the "Supported Formats" Tab
  • Highlight Dolby Digital and click the "Test" button

Does your receiver make the same awful noise?

share|improve this answer
    
No, I can hear the test signal. Hoewever, even though I only check "Dolby Digital" during the test, the test is performed with pcm coding only. The receiver does not show "Dolby Digital" while the test runs. –  Adrian Grigore Sep 7 '09 at 7:42

Had same problem installed Realtek AC97 software for windows 7, fixed my problem

http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=23&PFid=23&Level=4&Conn=3&DownTypeID=3&GetDown=false

share|improve this answer

I had the same problem as anybody here. That was after a default Windows 7 install with a Creative Labs Soundblaster Live! USB external device. After installing the beta drivers from Creative the device suddenly showed up in my Windows 7 speakersettings as a possible playback device. Now the SPdif pass-through worked okay. The beta drivers are currently hard to find. I had to revert to the turkish Creative site at http://tr.creative.com/support/downloads/

share|improve this answer
  1. Go to control Panel
  2. Click on Hardware and Sound
  3. Click on Sound.
  4. Set SPDIF-OUT as Default instead of Speakers. Done!
share|improve this answer

Hey Suggestion here, I had the same problem. On properties tab of S/PDIF, In advanced Tab un-tick "Allow application to take Exclusive control of this device. Everything will work fine.

share|improve this answer
    
this works, but my receiver does not get a Dolby Digital or DTS signal. Instead, the signal is decoded by Media Center, which results in degraded sound quality. How does that work for you? –  Adrian Grigore Feb 21 '10 at 18:22

protected by Sathya May 7 '11 at 16:52

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.