Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My network adapter are enabled and I'm getting "GENERAL FAILURE" even when i ping to 127.0.0.1

This problem shows up after an unsuccessful installation of some firewall. I removed it and I still have the same problem.

share|improve this question

closed as off topic by Revolter, Diago Nov 30 '09 at 8:41

Questions on Super User are expected to relate to computer software or computer hardware within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
any chance to post more details? maybe a screenshot of ipconfig /all –  Molly7244 Aug 26 '09 at 0:24
    
@Molly, sorry, no chances, i have even make an upgrade install and still having this problems, now i have a new copy of windows. i have tried everything ... –  Revolter Sep 4 '09 at 21:40

3 Answers 3

Is at least one network connection enabled? Is your NIC enabled? Does it work when you do it in safe mode with networking support? Do you have any 3rd party NIC software? This is almost always useless. Try restoring to a previous restore point.

share|improve this answer
    
i have tried restore the system but it doesn't work, and a have also uninstalled all 3rd party software and rebooted in "safe mode with networking". still have the same problem. –  Revolter Aug 25 '09 at 23:40

It sounds like the TCP stack might be corrupted. If so, here is a potential fix:

  1. Click the Start button, bottom-left of the screen
  2. Type cmd into the Search programs and files box and press Ctrl+Shift+Enter (runs the command prompt as administator and bypasses UAC if enabled)
  3. Type netsh int ip reset reset.txt and press Enter
  4. Type netsh winsock reset and press Enter
  5. Restart the computer

Failing that, pop in the Windows 7 install CD and cancel out of the installation wizard. From the same command prompt as above, type sfc /scannow and press Enter. Let it run through and restart.

share|improve this answer
    
this doesn't work, it seams i have installed an "IP filter driver" im looking how i can remove it.. i also heard about reinstalling the "tcp ip protocol driver" but in Windows7 its not simple –  Revolter Aug 27 '09 at 17:36
1  
Windows key + R (to get the Run dialog box up) | control netconnections | right-click your usual network connection and click Properties | see if the IP filter driver is in the list and uncheck it | restart –  Kez Aug 27 '09 at 17:41

If you can't ping 127.0.0.1 it sounds like your NIC is failing. Are you able to swap out the network card to test?

Did the problem just begin when you started to use Win7?

Edit: Based on your comment, have you tried a system restore since the unsuccessfull firewall install?

share|improve this answer
    
all the network adapters report the same problem, im getting this message just after an unsuccessful installation of some firewall. –  Revolter Aug 25 '09 at 23:30
3  
I think you have found your problem, then. Now just figure out how to remove that corpse of firewall installation. –  Joey Aug 26 '09 at 5:40
    
Not to mention, loopback (127.0.0.1) never hits your NIC (there isn't even a loopback interface). It's handled internal to the Windows TCP/IP stack. Go ahead and run wireshark, and try to capture data going to 127.0.0.1. hsc.fr/ressources/articles/win_net_srv/missing_loopback.html –  Jonathon Reinhart Apr 27 '13 at 7:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.