Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to access my Gmail messages in Apple's Mail app, using IMAP. I have successfully followed Google's guidelines, but I still have a problem: my sent messages don't appear in the inbox. I assume it may be logical, but I would like the threads to be "complete" just as in the Gmail web client. Any idea?

share|improve this question

migrated from stackoverflow.com Jun 15 '11 at 1:07

This question came from our site for professional and enthusiast programmers.

4 Answers 4

I think you are going to have to go to your [Gmail] All Mail folder to see the conversations the way you would like to. Mail that is on my Inbox also shows up as my mail and the others in conversations when I look in All Mail.

Gmail All MAil Folders

While we see an Inbox in Mail Google is just using Inbox as any other label.

share|improve this answer

This happened to me when I downloaded Mountain Lion. It included Mail 6.2. All my other folders, except inboxs, disappeared.The sent mail since the download is appearing.

In Apple Mail I created a Smart Mailbox and set the rules to be "From" Contains: "my email address" and then named the mailbox "Sent". Plus, I clicked to include all emails that are in "Sent".

In Google Mail I labeled all the "Sent" mail to be additionally labelled with the "IMAP Sent Mail". The IMAP folder was auto-created. (I don't know when)

When I went back to my Smart Mail Mailbox named "Sent" all the sent mail from me what there. When I checked the "Sent" box, I had complete threads of emails that were sent.

share|improve this answer

Obviously, you're not sending your mail via Google, only receiving it. You need to configure your IMAP client to place copies of sent messages into the INBOX folder. Apple tells you how to do this with Apple Mail.

For most IMAP servers, the IMAP server doesn't know anything about sent mail unless the client explicitly uploads a copy of every message that you send to the server. Google tells you not to do this, on the grounds that it expects you to be using Google's SMTP Submission server to send your mail. It has tied its SMTP Submission server and its IMAP server together. Google's SMTP Submission server makes copies of sent messages and itself adds them to your mailbox, meaning that your IMAP client does not need to.

share|improve this answer

Have you enabled threaded messages in Mail?

Are you sending mail from Gmail and not another account. Go to account preferences in mail.app and make sure you are using the GMAIL smtp server to send from that account.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.