Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've set user permissions on a folder in an attempt to have all files within the folder adopt the given permissions. I've also applied the "Replace permission entries on all child objects with entries shown here..." option from the Advanced dialog. The problem is, when I write new files into the folder, they don't adopt the folder's permissions.

Why is this? Can I make files automatically adopt the folder's settings automatically? What is the point and the meaning of folder properties otherwise?

The files are photos being imported from my camera. I'm using Picasa to do the transfer, which I guess is simply copying the files from the camera storage to the selected folder. They are saved to the "Shared Pictures" folder of the "All Users" folder because I want both myself and my wife (separate user accounts) to see them. But all new photos I import are invisible to the other user account until I manually edit the user permissions.

share|improve this question
up vote 0 down vote accepted

That setting just sets the permissions on the files and folders in the folder at the point in time when you click to set those permissions. Folder properties are to control what users can and cannot do. What sort of files are you trying to put in there that you would want to set the permissions for? What I mean is do they come from an App or do you copy them in there?

share|improve this answer
I've edited the question to better describe the files' origin. I suspect you're answer is correct, but I was hoping to find a solution. – user8405 Aug 26 '09 at 20:56

Properties > Security > Advanced

make sure Inherit from parent the permission entries that apply to child objects. box is checked.

share|improve this answer
and if not. click on edit on the advanced tab to set it – Chuck Aug 26 '09 at 0:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.