Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an 1.5TB WD External HDD, which I purchased in December 2010. Every few weeks, Windows stops being able to read it, and I have to fix it with a chkdsk /f. Now this is a little annoying, but not my main problem at the moment.

There is an Excel '97 file (.xls) on there that I really need to get the data from. However I can not see to access it at all!

I have tried:

  • Opening from file.
  • Opening from Excel (2010).
  • Copying the file.
  • Copying the file in command prompt.
  • Copying the file in cygwin.
  • Right-clicking on the file.

All of these cause Windows Explorer/Command Prompt/Excel to freeze until I unplug the External HDD.

Is there anything I can do to recover this file?

share|improve this question
up vote 1 down vote accepted
  1. I would see if the drive is under warranty (should be, most WD have a 3- or 5-year warranty), and have it replaced.
  2. I would not store valuable data on a drive I consider not trustworthy.
  3. I would also try chkdsk /r , which will try to exclude bad spots on the disk from being written to again.
  4. To recover the file, if the chkdsk /r does not do it, I would look at something like File Scavenger, which scans the disk for deleted versions (when it autosaves, for example). You could probably use a recent copy and recreate the few changes made since.
share|improve this answer
Thanks! chkdsk /r made it possible to retrieve the file! It's corrupt, but that's a whole other issue. – DanielGibbs Jun 16 '11 at 5:07

Try an Ubuntu LiveCD, boot it up from the CD (you don't need to install Ubuntu, it should run completely from the CD). After Ubuntu has started, the External HDD should appear as an icon on the desktop after you plug it in. From there browse through and try to copy it to ideally another USB memory stick, or other known good device. Ubuntu is pretty good at reading even NTFS partitions these days.

Ubuntu is a pretty large download though (600MB usually?) and a little overkill because it has so much other crap in it, so other people here might be able to suggest smaller Linux Live distributions which might be able to do this job. I just don't know any off the top of my head.

share|improve this answer

you may try the following freeware: it does work on .xls I personally used it on jpgs where it has excellent results

an other option (I also used it for jpgs) is the following: it has an ugly command line user interface and it has some problems under win7 (run it as administrator) but the results are also impressive:

otherwise there is the already mentioned way of using a linux rescue disk like: this will involve a lot of work on the linux console so it's the last resort! you'll easily spend hours with this! there are examples on the net, check out the documentation of sysresccd or follow the following guide below the title "ddrescue Syntax"

an other thought on the external disc: - if you use it on a laptop, make sure the laptop is NOT running on batteries - if you have a Y-cable (one with 2 USB plugs) make sure both are connected, if possible to USB ports that are not neighbors - make sure the cable is OK - make sure the drive is on a steady surface and it is lying flat

share|improve this answer
Ah yes, true story, I've had (rather old) hard drives that had errors when they were flat but worked fine on their side and weird things like that. – camster342 Jun 15 '11 at 10:12

Something else that might be worth trying as a real last resort is to take apart the enclosure, it will most likely be a SATA drive in there. Hopefully there might be break-down articles or YouTube videos for your model, telling you how to take it apart. You could then try plugging that bare drive directly into your motherboard (while the machine is off) and try to access it that way.

This is pretty unlikely to help though, as it sounds like it's most likely the hard drive itself is buggered, not the enclosure hardware. Be aware that this is extremely likely to break any warranty that you may have on the HDD and there is some risk that it may damage it beyond how it was before. Like I said, last resort if nothing else works and you really want one last chance at recovering that file.

share|improve this answer
hmm, though buggered MIGHT be a valid technical term, in some places, like 'borked' is, perhaps a slightly more universal phrase, such as 'is at fault' may be appropriate? – Journeyman Geek Jun 15 '11 at 10:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .