Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently I bought a JVC GZ-HM650 HD video camera. The camera produces *.MTS files, which Ubuntu 10.10 can't play correctly by default.

I would like to convert those files, so I can edit them in my video editing software. For video editing I use (OpenShot 1.2.2) Video Editor.

Unfortunately JVC only included Windows software to convert and edit video clips produced with their cameras. As far as I know, JVC doesn't have any Linux video editing software.

What's the best method to use, in order to convert my HD video files into a high quality playable and editable files? I already tried the following options:

  • Installing handbrake on my Ubuntu 10.10, but that didn't worked out! There were missing dependencies.

  • Using Arista Transcoder 0.9.6 and converting the *.MTS files with the preset "computer" to *.mp4 files. These files where playing correctly, the quality is good, but only the audio is 1.5 seconds out of sync. I don't know how to fix this problem in Arista Transcoder.

  • Using ffmpeg with the following commands:

    fmpeg -i INPUT.MTS -threads 4 -deinterlace -f avi-r 25 -vcodec libxvid -vtag XVID -s 1920×1080 -aspect 16:9 -maxrate 1800k -b 1500k -qmin 3 -qmax 5 -bufsize 4096 -mbd 2 -bf 2 -flags +4mv -trellis -aic -cmp 2 -subcmp 2 -g 300 -acodec libmp3lame -ar 48000 -ab 128k -ac 2 OUTPUT.avi
    

    (Original *.MTS file size: 159.6MB new file size: 426,4MB)

    The output is good quality, but the file size is enormous! All the files play flawlessly in the media players I have installed, but the files become far too big this way.

    ffmpeg -i INPUT.MTS -vcodec libx264 -vpre hq -crf 22 -threads 0 -deinterlace -acodec libmp3lame -deinterlace -ab 192k -sameq OUTPUT.mp4
    

    (Original *.MTS file size: 159.6MB new file size: 120.7MB)

    The output gives a good quality result, but large files stutter a little while playing them in VLC Media Player, Totem, and Gnome Mplayer. Smaller files (under 100MB) don't have this problem. Perhaps I have to tweak this command a little? I have no idea how, any suggestions on how to do this are welcome.

Are there better options to convert my HD video files to high quality, playable, and editable files? Or do you have tips on any of the above options I've tried?

share|improve this question
2  
Not programming related - you'll probably have better luck on one of the sister sites. –  paxdiablo Jun 15 '11 at 8:12
    
x264 is probably the best option, but I'm not sure what's wrong with your ffmpeg command. Handbrake (which uses x264) is probably the easiest to use (it's what I use) - could you perhaps post your dependency issues with that? –  user55325 Jun 15 '11 at 14:31
add comment

migrated from stackoverflow.com Jun 15 '11 at 9:37

This question came from our site for professional and enthusiast programmers.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.