Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not sure if this belongs here or on serverfault, but I already have an account here so this is where I'll start.

In my office we have a development server running windows 7 pro or server 2008 (I'm not sure which as I don't personally have access, but I can find this out if it's important), with network shares for each of the current builds. We've always done it this way, but it used to be a windows server 2003 box.

Anyway - periodically the server starts refusing connections from xp/2003 boxes, and there are errors in the server log about something running out of space; however we've found that someone rdp'ing into the server and running net stop server, net start server, net start "Computer Browser" fixes the issue.

This however requires for someone with access rights to stop what they are doing and do this about 2-3 times per week.

Is there any way to solve this issue permanently? It seems obvious that there is an issue with the windows legacy network share, but is this a setup issue that can be solved, or if not is there a seamless workaround such as some way of monitoring the error log and restarting the service as soon as there's a problem?


Having checked it's Windows 7 Professional


OK I got the error message from the windows server log :

The server was unable to allocate from the system nonpaged pool because the server reached the configured limit for nonpaged pool allocations.
share|improve this question

3 Answers 3

up vote 2 down vote accepted

Now that we have a full error message a quick Google search returns the following discussion on TechNet.

Apparently you need to tell Windows that you want to use the machine as a file server and that it should allocate resources accordingly. Set the following registry key to ‘1′: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

And set the following registry key to ‘3′: HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

After making these changes and restarting, I haven’t seen this issue arise again.

As always, edit the registry at your own risk. ;-)

share|improve this answer

I found the solution here - Windows 7 Professional does not have a half-open limit, however when you have a large number of people connecting you can get the OS running out of cache for it.

share|improve this answer

It sounds like you are probably periodically exceeding the maximum 20 SMB connections that Windows 7 (older versions allow 10) allows. The solution is to upgrade to a server OS.

Keep in mind that users can make more than one SMB connection to the computer, so you may still be hitting the limit.

http://www.winsupersite.com/article/win7/windows-7-product-editions-a-comparison (search smb connections on the page)

share|improve this answer
    
Windows 7, except for Starter if I am not mistaken, allows up to 20 connections. See this excerpt from the EULA: Device Connections. You may allow up to 20 other devices to access software installed on the licensed computer to use only File Services, Print Services, Internet Information Services and Internet Connection Sharing and Telephony Services. –  DragonLord Jun 15 '11 at 11:20
    
Okay, Starter also allows 20 connections as well. –  DragonLord Jun 15 '11 at 11:29
    
It looks like this is the problem - it's Windows 7 Pro. It won't be upgraded, you know what Technical Services departments can be like. Do you know any work-arounds? –  theheadofabroom Jun 15 '11 at 13:26
    
@BiggAl Write a script and toss it in a scheduled task that will do your net stop server, net start server, net start "Computer Browser" command for you? Have it run in the middle of the night when the odds of someone using the system are slim? Just a thought. –  N_Lindz Jun 15 '11 at 13:56
    
Hmm - if it's due to a 20 machine limit I'd say chances are slim - surely the connections would time out overnight? It's more likely that the randomness in occurrence is due to fluctuating usage patterns between departments. I stumbled across Half-open limit fix which looks like it would do the trick, but I'm not sure of the legality. Anyone? @N_Lindz @DragonLord –  theheadofabroom Jun 15 '11 at 14:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.