Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a NAS running FreeBSD/FreeNas 8.0.4 When I copy files from a windows system to it via SMB/CIFS normally (explorer/copy) it all goes fine. User can create/delete/update files

When i attempt the same thing with Robocopy. I get either of 2 errors, depending on command.

robocopy .\ \\freenas\temp *.* /FFT
2011/06/15 21:17:58 ERROR 5 (0x00000005) Time-Stamping Destination File \\freenas\temp\test.txt
Access is denied.

robocopy .\ \\freenas\temp *.* /COPY:DA
2011/06/15 21:18:08 ERROR 5 (0x00000005) Changing File Attributes \\freenas\temp\
Access is denied.

From the default config, I've set the following in smb.conf

[share]
map archive = yes

[global]
dos filetimes = yes

Any other clues?

share|improve this question
    
Here is the closest solution I've found. A upgrade to ZFS v28 freenas forum Which I'd have to wait to official get into the Freenas release cycle to verify –  Jafin Jun 21 '12 at 23:06
1  
For what it's worth, I have the same issue on a CIFS share on FreeNAS 9.1.1. Permissions are rwxrwx--- and my user is member of the group. –  abstrask Jan 11 at 14:15
add comment

3 Answers

Try using /COPY:DT to only copy data and timestamp info, not file attributes. You should probably keep using the /FFT switch too.

share|improve this answer
    
Still getting timestamp error. I've googled around and it just looks like some samba v timestamp issue??? But it's really hard to pinpoint exactly... Other say just use xcopy (which does work) –  Jafin Jun 21 '12 at 15:20
add comment

I had this problem copying from a Windows Server 2008 R2 machine to a Windows Server 2003 domain controller through an RDP client network share (e.g. \\tsclient\D).

Using an older version of robocopy from the Windows Server 2003 Resource Kit (XP010) worked fine.

share|improve this answer
add comment

Try copying over first in restartable mode /Z, then backup mode if that failes /B, so add the parameter /ZB and let us know what happens. It might solve your issue, but no guarantees. I would also be mighty sure you have your permissions and everything kosher.

share|improve this answer
    
Unfortunately I still get the changing file attributes error with both /Z and /ZB and /B. –  Jafin Jun 21 '12 at 15:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.