Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I realize that this might be a tough one but I thought I'll try nonetheless for there are many knowledgeable people here.

Skype recently shipped out an update which automatically installed a games application called EasyBits GO. I didn't want it, so when it first opened and asked for something (I don't remember what it was) I just closed it by clicking the titlebar X. After that, for some reason, Skype failed to work.

I think I noticed it on the next reboot: it just wasn't there even though I have it set to autostart. So, I started Skype manually. It showed the "Connecting..." screen for a few seconds, then suddenly crashed with a Windows messagebox telling me:

Skype has stopped working.
Windows is checking for a solution to the problem …

I closed, uninstalled EasyBits Go, uninstalled Skype, reinstalled Skype, same thing. I closed again, uninstalled Skype, deleted all Skype, Skype Extras and SkypePM folders from my user folder\AppData\Roaming and C:\ProgramData, cleaned my Registry with Eusing Free Registry Cleaner, rebooted and reinstalled Skype. Same crash on login!

I uninstalled Skype again, then restored the deleted stuff from the AppData folders and installed Skype 4.2. It works flawlessly and has even preserved my message logs. I tried to do an automatic update -- update works, Skype still crashes on login, so rollback to 4.2 again. Now it seems I'm stuck with this old version.

Are there any more steps I could take to get version 5 going again? Any ideas what could even cause this?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I had a similiar issue.

Goto the Skype icon and right click to Properties. What you will find under the 'Compatibility' tab is that Skype is suddenly running in a specific mode. Remove the option and ye should be back in business.

share|improve this answer
    
LOL. I had Skype running in Windows Vista mode on purpose, to be able to minimize it to the system tray. Glad to see they now offered an option in the Skype settings for that. Thanks for your suggestion, it worked! But why the heck it suddenly stopped working, I can't imagine. –  Felix Dombek Jun 17 '11 at 17:18
add comment

You could try using System Restore to roll your Windows Installation back to before Easybits Go was installed. That should put everything back to the way it was before the Skype install got broken.

  1. Open System Restore by clicking the Start button Picture of the Start button. In the search box, type System Restore, and then, in the list of results, click System Restore. Administrator permission required If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

  2. Follow the steps in the wizard to choose a restore point and restore your computer.

enter image description here

When you select the install point it should tell you waht software will be affected by reverting to that point. You'll have go back to a restore point before this update happened.

share|improve this answer
    
Damn! Why do I keep forgetting about system restore points?! I have even used them myself in the past ... thanks! Will let you know if it worked. –  Felix Dombek Jun 15 '11 at 15:15
    
I know the feeling, if I'd have remembered them when EasybitsGo installed itself I'd have used System Restore myself, as it was I went through blogtechnical.com/1115/… –  Mokubai Jun 15 '11 at 15:18
    
It seems I don't have any system restore points from before the problem ... I have seven restore points in the last 2 days, but the problem occurred 3 days ago. Darn it :( –  Felix Dombek Jun 15 '11 at 15:32
    
OK, last try, I did the things in your tutorial (most were not applicable though, because the folders weren't there, such as: no Go folder in AddData) now I'm trying another update ... –  Felix Dombek Jun 15 '11 at 15:43
    
hmmm ... nope. but thanks for your help anyway :) I'll just wait for v6 and hope that it will work again ... –  Felix Dombek Jun 15 '11 at 15:54
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.