Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just tried remoting to my work PC from home and got the "identity cannot be verified" prompt like the one below. I marked the "Don't ask me again for connections to this computer" box, and then accidentally clicked No (do not connect) instead of Yes. Now when I try to connect it asks me for my password, but then it does not connect and it goes back to the RDC login prompt.

How can I undo this setting? I looked in the MMC Certificates snap-ins, but did not find anything that looks related to my work computer. I also tried deleting Default.rdp, but there's nothing relevant in that file either. Any help is much appreciated!

Remote Desktop Connection Certificate prompt

share|improve this question
    
In the connection dialog if you click Options, then click the Advanced tab you can choose what to do if the server cannot be verified. Make sure it's not set to 'Do Not Connect'. –  James Jun 15 '11 at 14:47
1  
James, thanks for replying. I've tried each of the options there, and even "Connect and don't warn me" results in the same behavior, so I think my mistake with the "Don't ask me again" setting is overriding this. –  pibboater Jun 15 '11 at 14:51

2 Answers 2

up vote 7 down vote accepted

I would just go to HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Servers and delete the connection info for the computer that you want to reset. Next time you log in, type the name, and the request returns.

I tested this.

share|improve this answer
    
Perfect, this is exactly what I was looking for. Thanks!! –  pibboater Jun 16 '11 at 0:24
    
It seems like it doesn't work for Windows 8.. can't get certificate warning back.. –  Tarkus Aug 14 '12 at 21:07
1  
I don't think this is correct. The correct entry to delete is HKCU\Software\Microsoft\Terminal Server\Client\LocalDevices\<name>. –  Michael Steele Nov 26 '12 at 22:14

This worked for me as well in Windows 7. Due to this issue, I was strangely unable to login to RDP.

These are the steps I have done

1) Remove the Default.rdf from Documents folder. It will be hidden
2) Remove the RDP connection folder using regedit in the following folder
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Servers
3) Run mmc.exe. Add Snap In -> Cerificates -> Computer Account -> Local Computer -> Finish
Expand the Added Certificate -> Remote Desktop folder and remove the certificate issued.
4) Do Step 3 in remote desktop as well

Thanks, Sarath

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.