Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't know which of my action exactly caused this to happen but, I'm struggling with this behavior of Chrome for quite a few months now. Did a lot of search on this error, scrolled through many forum posts on the Chrome blog, tried their solutions but...in vain. It just won't update!

So..I

  • Tried re-installing Chrome
  • Tried uninstalling and then reinstalling Chrome
  • Not using any portable version or nightly..its as retail as it gets
  • Don't have multiple user accounts on my Windows 7, just a single user and that's me!

What I suspect?

  • Some issues with Google Updater (picked this up from the forums)
  • I use anti-frustration software Soluto, to delay some of my startup programs..I think this might be causing problems
  • But, I'm not delaying or pausing Google Updater (Why would I??)

Please help me to get back those sweet days when I would hit update and Chrome would update itself happily!

Thanks

share|improve this question

1 Answer 1

Error 3 is a failure to communicate with Google Update. There are two known reasons for this:

You're running Vista/ 7 and you have configured Google Chrome to always run as administrator.

This is a known issue with the Google Chrome auto-updating mechanism and can be avoided by simply running Google Chrome as a normal user. Additionally, keep in mind that for security reasons we recommend that you don't elevate the privilege of Google Chrome to administrator.

Google Update isn't registered properly.

To fix this, verify that GoogleUpdate.exe exists in the location specified in the Windows Registry Editor.

The instructions below involve viewing your registry. If you're uncomfortable or unfamiliar with this, you may want to consult your local computer guru before following these steps.

  1. Go to the Start menu > Run.
  2. Enter regedit.
  3. Click OK. The Registry Editor should appear.
  4. In the tree view on the left, navigate to the following directory:

    HKEY_CLASSES_ROOT\CLSID\{2F0E2680-9FF5-43C0-B76E-114A56E93598}\LocalServer32
    
  5. The "Default" value should correspond to the location of your GoogleUpdate.exe or GoogleUpdateOnDemand.exe file. Verify that GoogleUpdate.exe exists at the given path.

    • If GoogleUpdate.exe doesn't exist in this location, try uninstalling and reinstalling Google Chrome.
    • If GoogleUpdate.exe or GoogleUpdateOnDemand.exe exists at a different location, right-click the 'Default' value and select Modify. Enter the correct file path and make sure you use double-quotation marks, e.g. "C:\Documents and Settings\%USERNAME%\Local Settings\Application Data\Google\Update\GoogleUpdate.exe(or GoogleUpdateOnDemand.exe)"

Another thing you can try is to install the beta or dev versions of Chrome. That may very well clean up whatever is causing your problem.

Click here for links to the different Chrome "channels", where you can get the beta and dev installers

share|improve this answer
    
Ok..seems you got this from the forums. I've read this and already tried it. No, its not running as admin and GoogleUpdateOnDemand.exe does exists correctly at that particular key in the registry, and also exists on the filesystem...thnx for your help! –  detj Jun 15 '11 at 15:03
    
Have you tried installing the dev or beta versions? I run dev all the time myself (you get new features sooner). It should install a newer version of the updater also. –  bwall Jun 15 '11 at 15:14
    
Chrome prompted me today that it hasn't check for updates for quite sometime and asked me to relaunch it to install new updates..I did that and it upgraded to v12 something...As long as its updating I'm happy! @bwall: I'll try the dev/beta ones when I get sometime Thanks all the way –  detj Jun 16 '11 at 17:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.