Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've run into a problem on my HP laptop G32-301TX with i5 Intel processor and ATI Radeon graphics.

I have a dual booting with Windows 7 and at first Ubuntu 10.10 every thing runs fine till I upgraded.I found the new 11.04 being a bit slow and slightly buggy and dropped back to 10.10 after 2 weeks of use.

The thing about 10.10 is that it's sometimes freezes. One day its freezes and I had to hard boot it (manually force shutdown and start). afterward on start, it puts me on busybox.there were couple of times that I face the same scenario and I had to reinstall the GRUB using this post it worked for some time. After reading this (which I can see every time I start the machine ),I installed a fresh installation of 11.04 but I feel it was slow.

I've picked up a GParted disk and check my hard drive and it seems ok. so started working. this morning my machine is being slow and I restarted and then there is no GRUB, nothing like Oses list , only a blank dash blinking over and over.

I've just reinstalled the 10.10 back but still no GRUB list.I've put Windows 7 and didn't boot with it then I could see the list.booting in Linux puts me in terminal with intramfs prompt.

Question 1 How should I fix this ?

Question 2 The only thing I can see here is to reinstall Windows and Ubuntu later.IS that a GOOD idea? if yes which version should I use? 10.10 or 11.04 ?

Question 3 if I want to re-install my dual booting setup. should I format the Windows system reserve partition too?

I store most of my data on a separate partition so data lost will be limited.but this is a kind of mess because it's a work machine so I need to get it back ASAP.

share|improve this question

2 Answers 2

up vote 1 down vote accepted
  1. It seems your grub might have been corrupted. You can use an Ubuntu CD to reinstall the grub or recover the grub. See if that works.
  2. Personally I prefer Ubuntu 10.10 because I have found Ubuntu 11.04 to be buggy. It used to randomly log me out of my session sometimes, so now I have shifted to Ubuntu 10.10.
  3. I am not sure how that works, but I believe that if you reinstall Windows 7, it should automatically do that.
share|improve this answer
    
thanks bruv!! going for option 3 thanks for answering –  black sensei Jun 15 '11 at 17:32
    
by the way my issue with 10.10 is this Intel ips 0000:00:1f.6: failed to get i915 symbols, graphics turbo disabled –  black sensei Jun 15 '11 at 17:38

Neel gave you a more direct answer to your question.

For the longer term, something else could be amiss. I would suggest that this kind of problem is usually hardware related, have you excluded the HDD itself being faulty?

ie. did you do surface scans for bad blocks?

from windows:  
chkdsk /r c:

from linux:
You could start with a SMART tool:
sudo apt-get install smartmontools
smartctl --help

and then you could scan for bad blocks:
fsck -c /dev/sdXY
(where sdXY is the partition you want to check)

I'd start there.

If you did exclude the HDD from being a problem, you may have find a gem if you look in dmesg/syslog in your Linux installation (look in /var/log). You can access those files over a live-CD (mount the HDD's file-system and look in it)

This would work fine from a liveCD also, 'tail -n 100 -f /var/log/syslog' sit back and watch for a bit. If it's an active hardware issue it might show up. ie. in one bad laptop I came across, there was a faulty webcam device appearing/disappearing every second. That caused havoc in everything.

If you manage to boot in the windows OS, look in the event viewer, there might also be some hardware related error in there to point you in the right direction. Note: there will be plenty of messages in there, look for 'Errors' specifically the rest are mostly information messages

share|improve this answer
    
Hello from the time i check using fskc /dev/sda6 it says something clean. just that it was without the switch -c .From now i can't even boot in windows. I gave up , reinstalling windows even before Neel suggestion.It's taking pretty much time, suspecting hardware now.it's weird because the machine is only 2 month old –  black sensei Jun 15 '11 at 17:31
    
i was wondering how bad software can impact on hardware defect... –  black sensei Jun 15 '11 at 17:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.