Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having this problem where my fonts in Firefox changed to this weird ugly bold one and I can't seem to change it. My font settings are exactly the same as they are on my other computer and that one's fonts are normal. I'm running Windows Vista.

The top picture is the abnormal one and the bottom is a normal picture for comparison.

enter image description here

Here is a picture from my other normal computer for comparison

share|improve this question

4 Answers 4

up vote 1 down vote accepted

Font corruption is one possibility. Wrong firefox setting is another. https://support.mozilla.com/en-US/kb/Some%20text%20shows%20up%20bold%20after%20upgrade

share|improve this answer
    
Hey sorry I never got back to selecting the answer, it turned out that my arial font file was missing for some reason, I simple replaced it and the issue resolved completely. –  Ryan Stull Jul 12 '13 at 16:00

Have you checked if the same happens with IE? If yes, some of your fonts are corrupted. You can fix this by extracting the fonts from Windows Vista installation disc (if you have it) or use your favorite search engine and do a look up for Microsoft Core Fonts and Microsoft ClearType Fonts Collection. I assume you already know how to install fonts.

If IE doesn't show the same problem, however, you can first try to change the default font in Firefox ( Tools > Options... > Content > Fonts & Colors > Advanced... ) to any other font, restart, change the font back as before, and restart again. If this doesn't work, you'll have to wipe your Firefox profile, and create a fresh one. See here for more information on that.

share|improve this answer
    
Hey thanks, It turned out I was missing my arial.ttf font file, so It was using Arial Bold.ttf instead, I just copied it over from another computer and I worked. Thanks for all of the answers. –  Ryan Stull Jul 3 '11 at 19:55

Try going to View>Zoom and uncheck "Zoom Text Only". I loaded up FF on a VM, and tested it.

share|improve this answer
    
I'm using ff 4.0, where is view? –  Ryan Stull Jun 15 '11 at 21:14
    
In the menu. Is you menu somehow hidden? If it is, you can hold down the ALT key, and reenable the menu in View>Toolbars and click "Menu Bar". –  KCotreau Jun 15 '11 at 21:18
    
Ah, I tried it and I didn't work. –  Ryan Stull Jun 15 '11 at 21:26
    
I will see if I can find something else that makes that look like that. I really thought that was it based on my test. Looked REALLY close. –  KCotreau Jun 15 '11 at 21:28

I will delete this after you look at it, but compare your settings to this default found in Tools>Options>Content>Fonts & Colors>Advanced:

enter image description here

Otherwise, I might agree with the font corruption answer. If you post a pic of these settings, I may be able to help you re-download the font.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.