Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My system was working fine until I decided to resize my primary partition. To do this I had to reboot. During POST my BIOS hung right as it was detecting the different drives. I updated my BIOS to the most recent version hoping that would fix something but there was no change. I reset to fail-safe defaults and everything worked fine. I then narrowed the issue down to the IDE/AHCI mode of my SATA controller.

When I say that the BIOS hangs, I mean totally frozen. I have let it set for a couple hours and it accomplishes nothing. Another interesting thing is that when it freezes, I can't even get it to load Setup because it detects the drives prior to showing setup. What I have to do is unplug the offending HD and things will go smoothly.

My main concern is that I am seeing some the beginning signs of my HD failing. Is this the case? If not, what can I blame for the issue so that I can fix it and return to AHCI mode?

My configuration is as follows:

Gigabyte X58A-UD3 with latest BIOS (FF)
Win 7x64
WD Black 500 Gig
i7950
6Gig RAM
share|improve this question

1 Answer 1

up vote 0 down vote accepted

Most often I've seen this type of issue caused by an incompatibility between the system board and something connected to it. My first suspect would be the DVD drive. In any case, I would disconnect disks until you figure out which one is incompatible. Use a LiveCD OS to determine if you're able to boot with no hard drive. Remember to check that if you can boot to the CD without the HD connected that you can't boot to the CD when the HD is connected to verify that the problem is with the HD!

If your motherboard has a RAID mode in addition to an AHCI mode, try that. RAID mode typically offers the same features as AHCI plus some vendor-specific extensions which might help. Intel, at least, prefers you use RAID over AHCI just because of this reason even if you're not using RAID. You may also check the Western Digital website and the website for your DVD drive to see if there is updated firmware for those.

Finally, depending on where the freeze takes place it could actually be a problem with Windows. Windows 7 is supposed to handle AHCI being enabled after install, but often it does not. If you're having trouble, try this:

  1. Disable AHCI in the BIOS.
  2. Boot to Windows. Run regedit.exe.
  3. Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci. Modify the value Start to have data of 0.
  4. Reboot your system into the BIOS, and enable AHCI.

When you get back in to Windows, a bunch of device drivers will install, after which you'll be required to reboot again.

If the value is already 0, then it's unlikely to be Windows.

share|improve this answer
    
I haven't added or removed any hardware, the problem started after a reboot, so I don't think it is a compatibility issue. I have done more or less the procedure you have described and am confident that the issue is the HD. I have booted to a live CD with the HD un-plugged in AHCI mode (It won't boot with the HD plugged in). I then plug in the HD with the machine running and I can access it fine. Booting windows in IDE mode, the registry key you mentioned is set to 0. –  Icode4food Jun 16 '11 at 3:12
    
I guess I would check for HD firmware updates or ensuring the HD is connected to SATA0 (or, if it is, trying another SATA port). Then I would try other HDs in AHCI mode, then I'd try reinstalling Windows (or installing a second copy, or doing a repair install). If it's obviously the HD, contact WD for a replacement if it's still under warranty. –  Bacon Bits Jun 16 '11 at 3:20
1  
I have tried a different SATA port with the same results. I feel fairly confident that re-installing Windows won't do a thing be cause the BIOS is hanging when it is querying the system to see what devices are present. The thought of booting off of one of them hasn't entered the poor machine's head yet. :-) –  Icode4food Jun 16 '11 at 3:23
    
I also forgot to mention that I have checked for firmware updates of which I could find none. –  Icode4food Jun 16 '11 at 3:26
    
Yeah, I'd try another HD then. Optimally the same make and model, which would show that that particular HD was faulty. Essentially you're down to proving to Gigabyte that their motherboard is broken or proving to WD that their disk is. –  Bacon Bits Jun 16 '11 at 3:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.