Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When using the windows command ipconfig /all, the result will show a PPP adapter followed by a long name closed with braces. It looks like the below image:

enter image description here

When I try to set the DNS of my PPP adapter, I encounter this problem:

netsh interface ip set dns "PPP adapter {1C43A7B0-1173-40E2-96D6-1DA6457786B0}" static
Invalid interface PPP adapter {1C43A7B0-1173-40E2-96D6-1DA6457786B0} specified.

I have also used the pure string "{1C43A7B0-1173-40E2-96D6-1DA6457786B0}", but with the same result.

How can I reference this PPP adapter, so that I can change its configured DNS and other settings?

What does this long string mean?

I do not have this PPP adapter connection on my "show all connections" panel, because I have a VPN app - when running it, this PPP adapter will be automatically created for me.

share|improve this question
What are you using for your connection software? You may, or may not, be able to set it. –  KCotreau Jun 16 '11 at 2:57
For future reference, the number string you have there - {1C43A7B0-1173-40E2-96D6-1DA6457786B0} - is called a Globally Unique Identifier (GUID) or Universally Unique Identifier (UUID). (The difference between the two is essentially semantic.) –  Bacon Bits Jun 16 '11 at 3:02

1 Answer 1

I just tried your command with a PPP adapter I have, and I think your syntax is wrong. Try this:

netsh interface ip set dns {1C43A7B0-1173-40E2-96D6-1DA6457786B0} static

In other words, the reason it failed is that "PPP adapter" is not part of the name, and the GUID is just a name Windows gave that adapter in the registry.

share|improve this answer
If this works for you, please come back and mark the answer as accepted. –  KCotreau Jun 16 '11 at 3:08
Hi, thanks for all the replies and help, and I just tried the Kcotreau's method, but I'm sorry, it does not work either. –  ollydbg23 Jun 17 '11 at 4:47
2011-06-17 added: In fact, I use a L2TP VPN Client APP in my school, This is a dialing program. I need to supply a user name and password, after its dialing up, I can access to the world wide internet. Here is the result netsh interface ip set dns {1C43A7B0-1173-40E2-96D6-1DA6457786B0} static Invalid interface {1C43A7B0-1173-40E2-96D6-1DA6457786B0} specified. –  ollydbg23 Jun 17 '11 at 5:18
@ollydbg23 One more try: Try it without the {}. By the way, when I did it, I had an actual adapter name, not a GUID. –  KCotreau Jun 17 '11 at 11:01
Thank you Kontreau for the help, current I'm at home, I will test and give the reply when I return to my office at school. –  ollydbg23 Jun 17 '11 at 13:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.