Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using wget 1.12 (in msys if it makes a difference) and am trying to mirror a website with the -nd option, since the file and folder names on this site are very long. The docs state that

‘-nd’
‘--no-directories’
    Do not create a hierarchy of directories when retrieving recursively.
    With this option turned on, all files will get saved to the current
    directory, without clobbering (if a name shows up more than once, the
    filenames will get extensions ‘.n’).

However, this is not the case. The identically named files keep getting overwritten (think index.html on a large site). How can I get the correct behavior?

P.S. he reason the names are so long is that they are in Hebrew and are being converted to ascii %HH. Is there another way to do this?

share

merged by nhinkle Jun 16 '11 at 15:07

this question was merged with wget -nd (--no-directories) option not working as expected because it is an exact duplicate of that question.

migrated from stackoverflow.com Jun 16 '11 at 13:16

This question came from our site for professional and enthusiast programmers.

1  
possible duplicate of wget -nd (--no-directories) option not working as expected –  Linker3000 Jun 16 '11 at 14:06

Browse other questions tagged or ask your own question.