Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having serious connectivity issues in Windows 7 and I'm out of diagnostic ideas. Here's way too much detail:

  • Machine is about 6 months old, haven't had a problem up until yesterday.
  • Internet connection comes and goes, 'ping google.com' sometimes works, sometimes shows terrible latency and often times out.
  • pinging Google on my other machine (Mac laptop on same wireless network) works fine. No network issues.
  • First noticed the issue yesterday while running a VMWare VM-- all of a sudden, I could not connect to the VM by hostname or IP address

Network Setup

  • Cable modem
  • Wireless router
  • Wireless access point (running DD-WRT) that Windows 7 machine is plugged into via a Realtek PCIe GBE Family Controller ethernet port on motherboard

Things I've done to eliminate suspects

  • Called cable company to confirm they didn't see any cable modem issues
  • Reset router and replaced ethernet cable running from modem to router's WAN port
  • Replaced ethernet cable between Windows 7 machine and access point
  • Unplugged from access point, installed brand-new wireless NIC into machine, still saw issues
  • Shut off IPv6 on all network adapters on machine
  • Killed Windows Firewall
  • Disallowed Power Management's "Turn off device to save power"
  • Tried static IP and DHCP
  • Disabled VMWare adapters

I've walked through most of the ideas in this thread, including starting in Safe Mode with Networking (no difference) and the netsh resets.

EDIT: It seems to happen about a minute after the machine boots up. I cannot get System Restore to work.

share|improve this question
    
Maybe I am missing it from your post, did you uninstall and re-install the driver(s) for the Ethernet , did the driver(s) just update before this started? – N4TKD Jun 16 '11 at 21:23
    
No, haven't touched the drivers, though there were a fair number of Windows Updates in the past two days. Should I just back off to a generic MS driver? – Tom Jun 16 '11 at 21:39
1  
Is the Mac on the same AP as the win7 box. Also I am a little confused since you mention plugging into the access point and not connecting wirelessly. Is this a true access point or does it also have layer 2/3 functionality (is it a wireless router in access point mode)? Is it possible you are behind a double NAT? – Not Kyle stop stalking me Jun 17 '11 at 20:00
    
It's an old Linksys WRT-54G with DD-WRT on it, running as a bridge. I'm plugged into it and it's connected wirelessly to the main router. – Tom Jun 18 '11 at 15:47
    
Just plugged the laptop into the access point and saw timeouts at the same time as the Windows box. Looks like the access point's finally giving up the ghost. Thanks. – Tom Jun 18 '11 at 15:56
  1. Do a tracert google.com and see where it is slow.
  2. Go to http://www.speedtest.net/ and run a test there.
share|improve this answer
    
Yes, see above: I've connected via another laptop wirelessly with no issues. I don't think tracert will tell me much as most of the time ping never even connects. – Tom Jun 16 '11 at 18:53
    
Sorry, don't know how I missed that...let me think, and I will post back. I may have to leave for a few hours though. Have you pinged by IP address to rule out issues with DNS? Try ping 199.191.128.103 (an AT&T name server I use). Have you considered system restore going back to before yesterday? – KCotreau Jun 16 '11 at 18:56
    
No worries. I was actually just up on the machine and did a tracert and pinged Google's DNS server via IP (8.8.8.8). Nothing really interesting on the ping-- it was working fine, but I got fine responses intermittently. However, the tracert times out on the 2nd hop: it gets to the router, then shows a timeout and then continues on its way. Any idea what that means? Like maybe I have yet another crappy Linksys router? – Tom Jun 16 '11 at 19:15
    
Never mind: just means the modem is ignoring the request: reddit.com/r/techsupport/comments/fm4a1/… – Tom Jun 16 '11 at 19:18
    
It still may be your router is failing or corrupted. I have seen plenty where they do not fail all components at once, like maybe only the wireless goes, or maybe a port on a switch. Try plugging into a different port, and after, if not fixed, resetting it totally, and just rebuild the settings. – KCotreau Jun 16 '11 at 23:22

I would use the products latest driver, if it has just been update when the problem started, I would roll back to last driver that worked correctly, driver(s) can create these types of problems. I hope this helps

share|improve this answer
    
this may actually be the cause and a system restore will solve it. Sometimes the network type (public, domain, private) somehow is lost and has to be reset as well, or that has happened to me at least – datatoo Jun 17 '11 at 1:54
up vote 0 down vote accepted

Kyle helped me track it down-- problem was a hardware one (old access point).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .