Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to scan, using simple-scan, the UI says Failed to scan -- Unable to connect to scanner. When I run it from the command line I get:

joel@home:/usr/bin$ simple-scan -d
** (simple-scan:6554): DEBUG: Starting Simple Scan, PID=6554
** (simple-scan:6554): DEBUG: Restoring window to 600x400 pixels
** (simple-scan:6554): DEBUG: sane_init () -> SANE_STATUS_GOOD
** (simple-scan:6554): DEBUG: SANE version 1.0.22
** (simple-scan:6554): DEBUG: Requesting redetection of scan devices
** (simple-scan:6554): DEBUG: Processing request
** (simple-scan:6554): DEBUG: Requesting scan at 300 dpi from device '(null)'
** (simple-scan:6554): DEBUG: scanner_scan ("(null)", 300, SCAN_SINGLE)
** (simple-scan:6554): DEBUG: sane_get_devices () -> SANE_STATUS_GOOD
** (simple-scan:6554): DEBUG: Device: name="brother2:bus4;dev1" vendor="Brother" model="MFC-210C" type="USB scanner"
** (simple-scan:6554): DEBUG: Processing request
** (simple-scan:6554): DEBUG: sane_open ("brother2:bus4;dev1") -> SANE_STATUS_IO_ERROR

** (simple-scan:6554): WARNING **: Unable to get open device: Error during device I/O

FYI, I have already done:

joel@home:~$ sudo chmod a+rwx /dev/bus/usb
joel@home:~$ sudo chmod a+rwx /dev/bus/usb/*

If I run under sudo:

joel@home:~$ sudo simple-scan

it works.

How can I get simple-scan to work without sudo?

share|improve this question
up vote 5 down vote accepted

Chances are that saned doesn't think you're allowed to connect to it. See the Permissions Issues section of the Ubuntu Scanning Howto for details.

share|improve this answer
See my answer below for full details of what I did. – JoelFan Jun 17 '11 at 11:55
Seems that all user accounts aren't added to the scanner group. I used sudo adduser username scanner and then you need to log off and back in again for the group membership to be noticed by the OS. – KayEss Aug 1 '13 at 3:03
Did not work for me. I seem to remember that the only way to do it was using sudo and a text version not simple scan. Will keep looking – Dennis Apr 3 '15 at 5:17

I had a similar problem (Ubuntu 11.04 - Natty Narwhal): Scanning as root works fine, scanning as user – no go. scanimage -L and sane-find-scanner found and identified the the scanner correctly, even when run as normal user. `simple-scan -d both as root and normal user didn't show up anything useful in terms of missing group right, missing files or drivers.

Eventually this link worked for me.

The solution was editing these files:

  • /lib/udev/rules.d/40-libsane.rules
  • /etc/udev/rules.d/55-libsane.rules

Not sure if both needed to be edited, I applied all changes as described. Very important: REBOOT after editing.

share|improve this answer

Edit the following:


And change the:




Restart and test again – this should be working.

share|improve this answer
Something tells me this is not a desirable solution from a security standpoint. – Kazark Apr 12 '14 at 1:35

I solved it by adding this line to /etc/rc.local (before exit 0):

chmod -R a+w /dev/bus/usb

and editing/creating the following 2 files:


service saned 
socket_type = stream
server = /usr/sbin/saned
protocol = tcp
user = root
group = root
wait = no
disable = no


# Defaults for the saned initscript, from sane-utils

# Set to yes to start saned

# Set to the user saned should run as

then rebooting.

It's working, but I still would like a more secure way of solving this.

share|improve this answer

I had the exact same problem and this work for me and it is as simple as that. I actually copied from the Brother Website that solved my scanner problems:

  1. Open /lib/udev/rules.d/40-libsane.rules file.

  2. Add the following two lines to the end of the device list. (Before the line # The following rule will disable ...):

    # Brother scanners

    ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"

share|improve this answer

You need to add your username to the lp group and then reboot (or sudo ldconfig). Everything should be working.

This worked for me because if you run lsusb to grab the USB bus number of your printer/scanner (mine was 005) and then ll /dev/bus/usb/005 you will see that root is the owner and lp is the group, both have read and write permissions.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .