Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently purchased a nice asus 1000HE, and installed Ubuntu NBR. However, I'm pretty disappointed with how sluggish it feels. I'm wondering if I maybe need to install a closed-source graphics driver - it feels similar to how my work laptop performed before I installed the restricted nvidia driver on that machine.

[EDIT] In case it's any use:

pete@eliza:~$ uname -a
Linux eliza 2.6.28-12-netbook-eeepc #43 SMP Mon Apr 27 16:06:05 MDT 2009 i686 GNU/Linux
share|improve this question
    
I suspect bad drivers... –  Ivo Flipse Aug 26 '09 at 6:01

6 Answers 6

I doubt you need graphics drivers -- it's an Intel integrated video card. It should work out of the box with any Linux distribution.

As for your sluggishness, your problem probably lies in the fact that you're using GNOME & Firefox. A couple of tricks I learned to speed up my EeePC are:

  1. Turn Firefox's history off. Firefox's history function uses Sqlite3, which slows down the SSD dramatically.
  2. Try to avoid using GNOME is you can. Switch to a lighter desktop environment, like Xfce or OpenBox (This suggestions may be harder to achieve if you're new to *nix, or Debian in general)
  3. Make sure in /etc/fstab that all partitions are mounted with the 'noatime' option.
  4. Install prelink and preload and configure them (use Google to figure out how. It is too long to explain here)
  5. Try using easy-peasy instead of NBR. I've heard better things about Easy-Peasy, and I believe it's more optimized for SSDs than NBR is (don't quote me on this -- I personally use Debian)
share|improve this answer
    
I'm afraid your wrong about the Intel drivers - at least currently: h-online.com/open/Ubuntu-9-04-and-Intel-graphics--/features/… –  innaM Aug 26 '09 at 8:57
    
Thanks for the tips. The 1000HE doesn't have a solid state drive however, so some wouldn't apply in my particular case. Useful none the less. –  Pete Hodgson Aug 26 '09 at 22:48

It might be bug 349314, which caused Ubuntu Netbook Remix to be sluggish in a number of netbook models for some time. Check if your kernel version is at least 2.6.28-15.48, which should have the fix.

EDIT: your uname -a output shows you probably have 2.6.28-12.43, which definitely has the issue I mentioned (all kernels since 2.6.28-11.41 and before 2.6.28-15.48 should have that issue). You have to check the kernel and X.org logs to be sure if that is the cause in your case, however; see the bug report for details. Or you could simply upgrade to the latest kernel, which should be 2.6.28-15.49 and have the fix.

share|improve this answer

Notes on Asus Eee 1000HE (and newer) maybe useful.
Though, I don't see any thing specific yet.

This page hosts user submitted configurations and recommendations for getting the most out of your Eee.

Just to confirm, you are using the Eeebutu NBR? check this discussion too.
And the ASUS Support page for reference.

I have two tips (besides your graphics driver point),

  1. Check your memory utilization -- are you near peak? is swap being used?
  2. If you feel the network access is sluggish (terminals work fast, browser stalls) check the network path is good
    I also read about some WiFi troubles on those links.
share|improve this answer
    
I'm using the vanilla NBR downloaded from ubuntu.com –  Pete Hodgson Aug 26 '09 at 22:48
    
Sorry, my previous comment was actually not quite true. I used vanilla NBR but installed the eeebuntu.org/index.php?page=array array kernel from eeebuntu to get my wifi working. –  Pete Hodgson Aug 26 '09 at 22:50
    
I edited my question to include specifics about which kernel I'm running –  Pete Hodgson Aug 27 '09 at 1:06

Did you create a swap partition during installation?

share|improve this answer

If you still have this Eee and never resolved your speed issues, if you haven't upgraded to Karmic it might be worth doing. I have a 1000 HE too, and Karmic has a new driver stack for the Intel GMA 950 in our Eees. It's a vast improvement, for the most part. The one downside is using the external monitor is even worse than it had been under Jaunty. You have to disable Compiz to use the Display preferences tool to turn on the external monitor, turn off the internal display, then turn Compiz back on. But if you don't use an external monitor, Karmic is definitely worth it!

share|improve this answer

Just found this page about Troubleshooting Intel graphics performance issues. When I'm in front of my 1000HE I'll investigate more.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.