Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've an Acer laptop with Windows 7 64 bit and an ATI Radeon HD 6550M Graphics card. Whenever I connect the power to charge the battery it automatically switches to the high-power GPU (ATI) instead of the low-power (Intel) GPU.

There's an option in the bios to stop such thing but it makes the GPU runs always on high-power and I can't switch to the low-power GPU.

How can I prevent the switchable graphics from automatically using the high-power GPU when charging?

share|improve this question
Do you want to completely disable the ATI card? – viking Jun 17 '11 at 14:17
Not at all, I just want to have the option of doing the switching myself. – Saifallah Jun 17 '11 at 14:24
What Acer model do you have? – viking Jun 17 '11 at 14:28
Aspire Timeline X (5820TG) – Saifallah Jun 17 '11 at 14:31
Have you looked at Power Settings, Power Profiles in particular, and the advanced graphics settings? (These a general things, not specific to Acer) – viking Jun 17 '11 at 14:39

4 Answers 4

up vote 8 down vote accepted

Right-click on the Desktop and choose the option for "Configure switchable graphics". In the dialog that appears, you will see an option for "Automatically select power-saving GPU when on battery". This option controls whether the graphics switch automatically. If you uncheck the box, then the GPU should only switch when you manually change it using the specific buttons.

AMD switchable graphics

(Note, this is the procedure on my HP laptop with ATI switchable graphics. I assume it is the same or similar for your Acer, as the drivers should be the same, but I can't guarantee that it'll work.)

share|improve this answer
That's my main problem. I've the same window with the settings in the middle but without the content (the yellow thing) and the rest. – Saifallah Aug 3 '11 at 8:31
Well now that's odd. Have you updated the graphics drivers to the latest version? – nhinkle Aug 3 '11 at 15:11
Yeah just did yesterday. But now it's a little bit different (on the eye) and the option is still missing. – Saifallah Aug 4 '11 at 8:57
No more a Windows user. I'll mark this answer as correct. – Saifallah Oct 15 '12 at 13:56
Saifallah, Please see my answer here:… – marcolopes Jun 12 '14 at 16:07

I solved it by uninstalling Acer Powersmart Manager

share|improve this answer
Why downvote this answer? It's actually correct: if you don't uninstall Acer Powersmart Manager, it will keep forcing the switching of graphic card when charging (even if you disabled the auto switching as in nhinkle's answer). Uninstalling it also fixed the issue for me. – gaborous May 14 at 15:37

/EDIT: for 4820TG and 5820TG laptops, you have an INSYDE bios, so the tutorial below won't work (it works only for Phoenix BIOS like in 3820TG). To check the BIOS you have, you can just type in the Start Menu: "System Information" and open the application that shows up. Inside the list, you should find "BIOS version/date".

If you have the INSYDE bios, you can flash your BIOS using this mod (works directly from Windows, it's a simple executable, and you can always reflash the old bios if something goes wrong):

It will add several hidden entries, one of those will be an option "Integrated" for the GPU. I tested and it works great. And indeed, disabling the high-power GPU from the BIOS is the only way to prevent it from sucking energy and from overheating your CPU (because it logically disconnect the card, so that it's just like as if you physically removed it). You can always re-enable it later from the BIOS when you want to use it.

Here's an additional tutorial to learn how to mod your BIOS by yourself to show the hidden menus:

/OLD POST: An alternative is to mod the BIOS to unlock the hidden Intel menu (it seems to be a classic in Acer products line). There are two ways:

1- by temporarily overwriting the BIOS in NVRAM. For this you need to use a floppy disk or an USB key to boot into DOS and then use a program called SYMCMOS.exe. This is a very good solution because you don't risk very much: if you do a bad manipulation, you can just reinit the bios (either from the bios menu by blindly hitting the shortcut keys to restore the default config, or either by hardware reset of the CMOS battery) and the bios will be back to factory defaults without your NVRAM modifications.

2- by really modifying your BIOS by flashing it with a modded BIOS. This is riskier because there's no way back if it goes wrong.

Using this hidden Intel menu, you can force set either the high power gpu or the low power integrated gpu or switchable graphics (auto, the default).

To my knowledge, this is the most foolproof way to fix the issue, and it works for all OSes since you do the modification at the BIOS level.

For more infos, see:

Alternatively, before trying the bios approach, you can try on Windows to disable the high power gpu in the Device Manager and uninstall Acer Powersmart Manager (otherwise this software will still force switch to high power gpu even if it's disabled! Making the OS crash).

Also, you may need to disable "Automatically select power-saving GPU when on battery", and if this option doesn't appear in your Catalyst panel, then it's because your driver doesn't support it. But you can install one that does from leshcatlabs's UniFL drivers list (select one with "Fixed Mode" driver):

share|improve this answer
  1. Go to graphic properties, "catalyst control center"
  2. Click on the Power tab
  3. Click on "Disable Power Play"
share|improve this answer
PowerPlay is not related to AMD switchable graphics. PowerPlay refers to a mechanism for controlling the power consumption of a GPU, not switching between a high-performance GPU and a power-saving GPU. – bwDraco Sep 9 '12 at 15:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.