Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I accidentally (too less sleep) formatted a ntfs partition (system-partition of windows 7) that I actually wanted to clone with imagex (yes, you may laugh at me). If that wasn't enough, I first forgot to use the /q-switch for quick-format, canceled at 7% and formatted it again using the /q-switch.

I then tried to recover it using testdisk. After scanning the harddisk, it says that it can't recover my partition. Is there any possibility to trick testdisk for at least a partial recovery of that partition?

(btw: please do not mark this as dupe. I know how to recover files and in fact photorec would work. But it is important to recover the partition at least partially. So this is not a simple "recover files from deleted ntfs-partition"-question)

share|improve this question
up vote -1 down vote accepted

I think that your file-system is lost (i.e. you killed it twice). the way that file recovering works is it looks for areas that are marked as unused, or marked for deletion or whatever. you just removed that information, and the structure that you now want to save. Don't think you can recover half a filesystem and if if you could it would not be meaningful (how good is a word file with every other character junk?).

share|improve this answer
thanks... finally i tried to recover the files with photorec. I don't know if every file was recovered, but I think I have nearly all. – wullxz Jun 24 '11 at 11:28
-1 Doing a simple quick format doesn't affect disk data... There are other tools to testdisk that can recover it as well. GetDataBack being one of them. – Robert Koritnik Dec 15 '11 at 13:28
@RobertKoritnik, It is not about affecting the disk data (the folders stored etc) he wants to recover the filesystem (MFT). That part of the disk IS wiped during a format. – soandos Dec 15 '11 at 18:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .