Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on a Debian Linux machine using Icedove for email. (Icedove is nearly identical to Thunderbird but renamed by Debian.) The Icedove app is old, so I installed a newer Thunderbird downloaded from the mozilla.org site. I copied the user profile (named xxxx.profile where xxxx are several random characters) from .mozilla-thunderbird (used by icedove) to .thunderbird (used by genuine thunderbird) along with profiles.ini

When I run Thunderbird, it fails to connnect to the imap server. When I run Icedove, it works fine, getting and sending emails.

I checked all the settings in the Account Settings for the server. Server name, port number, etc. It all matches, except for Icedove shows only a checkbox for "use secure authentication" while genuine Thunderbird has a drop down list offerering several choices: normal, encrypted, kerberos, NTLP, and "any secure method". The last one was selected.

Icedove is version 2.0.0.24, and Thunderbird is version 3.1.10.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I don't know why Thunderbird is having problems, but there were likely config file changes between the versions that need to be migrated.

More importantly, why aren't you using icedove 3.0.11 from Debian? It's available in squeeze, and if you're still on lenny, you ought to be able to find it in backports. If you're on etch... you'll probably have to compile it yourself, which may not be worth it.

If the answer is that 3.0.11 isn't new enough for you, then I have to wonder why 3.1.10 is, considering that 3.6 and 4.0 are out now :)

EDIT: Debian Backports is a great source for newer software backported to older versions of Debian.

share|improve this answer
    
I'm new to using Debian, so "squeeze" to me is what one does with lemons :) I'd be happy with icedove 3.0.11 if I knew my way around these things. –  DarenW Jun 17 '11 at 22:40
    
Which version of Debian are you using? The latest version is 6.0, codenamed squeeze. The version before that, 5.0 was called lenny. And before that, 4.0, was called etch. If you're using the latest, then just use aptitude or your favorite package manager to install 3.0.11. If you're using lenny, you'll want to add the backports mirror to your sources.list, then do the same. And if you're on etch... then you really should upgrade. :) –  Flimzy Jun 17 '11 at 23:02
    
Using Lenny, thinking I ought to upgrade entirely to Squeeze anyway. –  DarenW Jun 17 '11 at 23:05
    
Lenny is my guess, too, based on the version of icedove you said you were using. Squeeze has much newer software... BUT! A warning: I was disappointed (as were many others) with some of the changes in squeeze--especially relating to KDE, and other graphic/UI elements. The newer KDE, and many of its associated apps, are prettier, but less functional and less stable in squeeze. For now, I'd suggest just adding backports.org to your sources.list, and installing the newer icedove from there. –  Flimzy Jun 17 '11 at 23:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.