Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have motorola cable modem with IP 192.168.100.1. It has DHCP in it switched on. To this modem is connected WIFI ADSL router EDIMAX through one of the four ethernet port. I read that I must turn off DHCP on this router to make it switch. IP DHCP pool of modem is 192.168.100.11 - 192.168.100.42 so I set the ip address of router to 192.168.100.100. I am connecting through wifi to the router. I set this info to my notebook: IP 192.168.100.101 mask: 255.255.255.0 and gate: 192.168.100.1

Now I can ping the router and modem well. But I can not go to internet. Cannot ping for example google ip address. Do you have some advice how to connect more computers through wifi router to modem and to have internet accessible?

share|improve this question

migrated from serverfault.com Jun 17 '11 at 23:21

This question came from our site for professional system and network administrators.

    
is the modem connected to the router on the router's internet port or one of its local network ports? –  Michael Lowman Jun 17 '11 at 17:16
    
modem is connected on one of its local port (1 of 4) 5th port is adsl port RJ11 not RJ45 –  foxo79 Jun 17 '11 at 17:25
    
do i have to set something special in router? NAT? BRIDGE? MAC addres spoofing?? I think i have tried this, but not sure. –  foxo79 Jun 17 '11 at 17:32
    
I'm not sure what the bridge option is; it would be required if it enables a wired-wireless link. The other two would not be, and I'm not even really sure why NAT is an option. –  Michael Lowman Jun 17 '11 at 17:36
1  
Although the physical configuration is not ideal, it is fine and functional. The wireless router's WAN settings are irrelevant in this configuration as its WAN port is not connected to anything. –  user48838 Jun 17 '11 at 17:47

3 Answers 3

You need to set your notebook's default gateway to the modem (192.168.100.100), not the wireless router. The modem is connected to the Internet while the wireless router is not in your configuration.

share|improve this answer
    
you made mistake. my modem has ip 192.168.100.1. so i have set it right. –  foxo79 Jun 17 '11 at 17:29
    
Ok, so what are the DNS servers on your notebook and what are the results when you ping 98.137.149.56? –  user48838 Jun 17 '11 at 17:45
    
i do not have set DNS servers yet, i am only trying to pign ip addreses and the result is in slovak but something like time has elapsed. and the loss is 100% –  foxo79 Jun 17 '11 at 17:49
    
What are the tracert/traceroute (Windows vs. everything else) results? –  user48838 Jun 17 '11 at 17:52
    
tracert gives nothing at all –  foxo79 Jun 17 '11 at 18:23

Is your laptop acquiring a IP through DHCP? If not, it should. This will properly configure it for access.

Second, check your modem and your router configurations; they both should have a built-in ping utility to test connectivity. Use these to check Internet access from both.

Last, check if your laptop can connect when connected to the router with a wired connection.

share|improve this answer
    
The wireless router's diagnostic may not function correctly against WAN points/addresses as its WAN port is not connected to anything in the described configuration. –  user48838 Jun 17 '11 at 17:49
    
i have static ip on my laptop from the range of modem. If i do not use static ip and try to get it automaticaly it will not connect me to network. so it seems DHCP from modem does not work. modem has only one utility: turn off and turn on DHCP. Do not have another wire cable to test wired connection. –  foxo79 Jun 17 '11 at 17:52
    
can you print a routing table from the router? it's possible it isn't acting properly and is trying to forward packets out the (unconnected) wan interface –  Michael Lowman Jun 17 '11 at 17:54

Check your router's configuration. Most routers with built-in modems got an option to disable the modem and use the wan port to connect it to an external modem. Otherwise it might still try to relay packets to the wrong ports.

For more specific help you should provide a traceroutes: to your router, to your modem, to another PC connected through ethernet, to another PC connected through WiFi (if possible).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.