Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This occurred after a Trojan incident. We managed to get the Trojan cleaned off the computer, but now we can't Right click the desktop. We have tried changing HKCU/software/microsoft/windows/current version/policies/explorer/noviewcontextmenu in the registry, and group policy user configuration/administrative templates/windows explorer/remove windows explorers default context menu, but neither worked.

How do we reenable the right-click menu for the desktop? (it works everywhere else)

share|improve this question

Sounds like it's not opening due to a corrupted or faulty menu entry...

You can enable/disable and remove Shell menu entries using ShellMenuView from Nirsoft.

Perhaps it can lead you to a culprit.

share|improve this answer

I had this exact problem....due to FakeAlert Trojan. All files on c: were hidden, desktop image was removed, desktop Icons were removed, Start Menu items were gone...along with all the garbage alerts about hard disk problems.

I removed FakeAlert with MalwareBytes and SuperAntiSpyware, but at least in my case the system was still only half repaired, but at least the trojan was removed.

After some research, I had to run the "attrib *.* -h /s /d" command from c:\ to see all of the files again. I ran this from a "cmd" window (i.e. a DOS command line). But at that point the desktop was still blank and I had no right-click context menu on the Desktop. Also, since the START menu was blank, I had to lauch the "cmd" from the Task Manager, with "File - New Task (Run..)"

The Nirsoft tool mentioned above was neat, but didn't help with this.

I finally found a little script (for XP only) at http://www.kellys-korner-xp.com/xp_tweaks.htm ...which re-enabled the desktop icons and right-click context menu on the Desktop. The script is called "Enable/Disable Desktop Icons", and it worked like a charm. When it is run, the script will toggle-on / toggle-off (depending on current state) the icons. If it ys that they have been disabled when you first run it, just run it again, and it will enable them.

Once I had control of the Desktop again, I re-enabled my Desktop background...but this is in "Control Panel - Display - Properties" anyway.

Good Luck!!

share|improve this answer
    
As you can see by the date on this question, it's about 9 months old. I've long since stopped working on the problem. In fact, I can't even remember what I did, probably just reformatted the machine. – Robert Harvey Mar 27 '12 at 22:52
    
Yes, I figured it was resolved by now, but wanted to post a fix that worked for others to use. Too bad you had to reformat. Too many times this is the case due to garbage malware issues. Regards. – TxAg Mar 27 '12 at 22:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .