Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My motherboard is an Asus K8V-X. I was using a 250GB Maxtor SATA hard drive ever since I bought this computer, and the dreaded click of death finally showed up. So I bought a new 500GB Samsung SATA hard drive before the old one gave out.

My problem is that when I install the new hard drive and turn on the computer, it doesn't get detected, and this message shows:

HardWare Initiate failed, Please Check Device!!!
The Bios does not be installed. Press <g> to continue!

I typed the message exactly as it appears on my screen. I figured out I might have to update the motherboard's BIOS. Found new BIOS versions to download on ASUS official website (here), but I don't know how to update it using them.

This is how my current BIOS screen looks like, except that mine is V2.54 Copyright 1985-2003, and doesn't have the Tools item, which apparently is exactly where I should go to update the BIOS, according to this post:

enter image description here

While updating the BIOS might solve my problem, I'm not really sure if this is the correct solution for this particular problem. What should I do?

UPDATE: I tried to follow the instructions on this link from Asus support to update my motherboard's BIOS. Got AFUDOS and the latest ROM file from ASUS website. When I ran the afudos exec on a cmd screen, it game me an error: ERROR: This program must be run in MS-DOS mode. How do I run it in MS-DOS mode from Windows 7?

UPDATE 2: Managed to run afudos by making a MS-DOS bootable flash drive. Apparently, it updated the BIOS but the BIOS configuration interface is still the same. I'm pretty sure it updated successfully because before the BIOS configuration interface shows up, there's a screen displaying an updated BIOS build date. Cleared the CMOS data by the jumper method and rebooted the PC. Problem still stands. Went to the store where I bought it, tested another new HDD and the same problem occurs. Forgot to test my new HDD on a new computer, just to absolutely rule out a HDD defect, but since another new HDD had the same problem, chances are that my computer is at fault. I'll have to wait till monday before looking for a way to definitely test the new HDD.

share|improve this question
add comment

2 Answers

I don't think that updating the BIOS is a bad idea at all in this situation. After that, that drive should be found automatically as long as both the power and data connectors are well-seated. If not, you may just have a DOA drive. Also, try swapping out the cables.

I also found this unusual solution on the web: A suggestion on the ASUS site in relation to this error was to press the re-set button in the search period (I am not sure what this means exactly, but you may understand since you will be watching it) before the error message came up. It worked for at least a few people.

share|improve this answer
    
One more thing to try: Reset the BIOS settings to default. –  KCotreau Jun 18 '11 at 1:25
    
I assume that the 'search period' is the time when it is scanning for devices, before the error message came up. I just tried the reset thing and it didn't work for me, unfortunately. Also I don't have another computer where I can try the new hard drive, so I can't rule it out as the problem. But I'd like to try to update the BIOS first. I'm trying to figure out how to do that. –  David McDavidson Jun 18 '11 at 1:28
    
I would asssume that resetting the BIOS to default settings is probably on the tools menu. That is quick and easy to try. –  KCotreau Jun 18 '11 at 1:42
    
Its easy enough to reset to default settings. Didn't solve anything unfortunately. Just tried to remove the motherboard's battery but couldn't with the tools I have here. –  David McDavidson Jun 18 '11 at 1:45
add comment

Is the hard drive connected via SATA?

Your best bet when it comes to hardware stuff like this (or any other problem really) is to try and remove all the points of failure. Take the hard drive and try it in another computer, using both PATA and SATA. Try different cables in your desktop (this probably won't yield anything seeing as you said your old hard drive worked fine). Once you've rules out the HDD as being an issue then you can safely say if the mobo.

As for BIOS updates, there might be an intermediate update that you can install without the "Tools" menu, which then gives you the "Tools" menu.

One more thing, try removing the CMOS battery on your mobo for about 5 minutes. Then put it back in and reboot. That might change something.

share|improve this answer
    
Yes, its connected via SATA. It doesn't have PATA slots, as far as I know. I don't have other computers to test the new hard drive, unfortunately. –  David McDavidson Jun 18 '11 at 1:32
    
According to the specs it should have both VIA VT8237 SATA and ATA-133. –  Hennes Sep 8 '13 at 18:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.