Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have some older hardware (Celeron dual-core) that I've just installed Ubuntu Server 11.04 on. My intent is to use it primarily as a file server, but I thought it'd also be fun to try and run a Team Fortress 2 server on it. I connected via SSH and downloaded and set up Valve's Linux Steam client, and started it installing the TF2 dedicated server. In order to do this it has to download all the game resources, some 7-8GB. My internet connection isn't very fast (I'm at a remote university with a very fast internal network but limited uplink), so I expected the download process to take quite some time. I started it and left for work.

When I came back from work (4 hours later) PuTTY on my Laptop showed "connection lost." I figured my laptop had temporarily disconnected from the WiFi for some reason and didn't worry, since I had started the Steam download in Screen. I tried to reconnect, but PuTTY said the connection timed out. I pinged the machine with no response. I connected a keyboard and monitor to the machine to check things out, and found that the Steam download had also stuck at around 60%. I checked ifconfig and it still showed proper network information. I tried pinging the internet with no response. I tried pinging a router on campus with no response. I then tried pinging the gateway for the residence hall network, still with no response.

I thought it might be a one-time fluke and restarted. After the restart the network connection worked fine, so I started the Steam download again at the local console. It looks like it resumed from where it had stalled, but a couple of hours later I came back and it was stalled again. I opened Lynx to check if perhaps the machine had somehow been unauthenticated from the RADIUS/web-login secured network, but instead of getting a login prompt it timed out. I tried the ping checks again and got nothing back.

I've now discovered that SFTP transfers larger than around 1MB will reliably cause the network to drop. Running sudo /etc/init.d/networking restart will bring network back, but sudo service networking start and sudo start networking will both just result in Networking stop/waiting.

On the other hand, I can run a TF2 game for ages without it going down. I theorize this is because TF2 is entirely UDP traffic. When I check /var/log/syslog after the network goes down, I don't see anything that looks abnormal (a couple of entries from a cronjob I set running, messages from named starting and what look like some PHP maintenance tasks, and a message from the kernel about no IPv6 routers being found that also appears before the network goes out). I have disabled IPv6 and the problem hasn't gone away.

The network controller, if this is relevant, is a SiS 191 Gigabit.

Any ideas on what's going on here?

share|improve this question
1  
This looks like a bug in the kernel driver for your NIC. You can report it to the Ubuntu developers by running apport-cli linux. –  Patches Jun 18 '11 at 7:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.