Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I installed Windows XP, I didn't install support for my native language: Croatian.

I used a friends CD created with nLite and the languages where removed. How can I install the correct keyboard layout without re-installing?

There is no Croatian to choose from when I go to selection language

share|improve this question

6 Answers 6

up vote 2 down vote accepted

If nLite was used to strip the languages out, there is no way to install them afterwards. nLite warns about this during the creation of the new CD, as this is tightly controlled within Windows. As per the nLite forum here, to install a MUI you also need the Help & Support component.

MUI require "Help & Support" component 

You could use your install CD and try and do a repair on Windows XP, however I am not sure if this will work.

share|improve this answer
    
worked; thanks for help –  bbaja42 Aug 26 '09 at 9:50

Copy the file kbdcr.dll from another (Croatian) Windows XP computer to your folder c:\windows\system32 (or expand from an original Windows XP CDROM)

Open regedit and navigate to HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ keyboard layouts and search for kbdcr.dll (0000041A on my machine, when I Google it says 00020405 for Croatian keyboard layout, but I found Czech/programmer in this folder)

now edit the Registry Key HKEY_CURRENT_USER\ keyboard layout\ preload, change the "1" value setting to the matching key from HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ keyboard layouts (e.g. 0000041A)

Done and Dusted!

(Note: Preload\2 is used if you want to be able to switch between two keyboard layouts.)

share|improve this answer
    
+1 Manual labor. Painful. But it does work thought. –  Diago Aug 26 '09 at 12:34
    
i was quite active in a netbookforum back then when they first came with tiny SSDs and nLite was touted to be the best thing since sliced bread. of course many users went overzelous and ripped a needed keyboard layout ... so i'm quite used to this particular question. :) –  Molly7244 Aug 26 '09 at 16:36

i tried that; but there's isn't Croatian (and many other languages) showed there;

You'll have to use a different installation disk (one which has all regional packs installed, and it doesn't matter which XP edition it is) to install Croatian, after you installed 'nLite' Windows on your machine. CP - Regional... - Install/uninstall additional languages You don't need to reinstall or repair, the problem will only repeat itself if you do it with a 'nLite' installation disk.

share|improve this answer

Have your language bar turned on, right click it, settings, add your keyboard and do not forget to have Windows never change it for you based on what you type.

share|improve this answer

You can install support for Croatian after installing Windows XP. See Control Panel->Regional and Language Settings.

share|improve this answer
1  
i tried that; but there's isn't Croatian (and many other languages) showed there; –  bbaja42 Aug 26 '09 at 8:57

http://hr.download.hr/program-cro-keyboard.html

I hope this helps!

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Tom Wijsman Nov 20 '12 at 23:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.