Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wanted to use my Linksys router as a wireless bridge/repeater so I decided I would change the firmware to DD-WRT. The first thing I did was downloaded vxworkskillerGv8-v3 and the DD-WRT firmware build 14929. For tftp I used the Windows GUI app on the DD-WRT wiki. I then configured my Windows 7 PC to turn off CTCP and changed my ip configuration to static with my ip 192.168.1.100, 255.255.255.0, and 192.168.1.1.

I then did a 30/30/30 reset on the router and once that was done I plugged my PC into port 1 with no other cables plugged in, went into the administration tab, and upgraded the firmware with the vxworkskiller. This is where it gets strange, the wiki said it would take a few minutes before it would say that I need to restart the router, but for me the progress bar got a few ticks and after about 10 seconds it told be to reboot, so I did. Then I used the TFTP GUI software to load the DD-WRT firmware onto it, and it didn't take any retries and took about 5 seconds.

After that I let the router sit for about 3 minutes and tried going to the web page: It didn't work. I then tried rebooting it but still wouldn't work. Finally I did another 30/30/30 but it STILL wouldn't go to the web page. This whole time, my port 1 light is on and I can ping it without a problem in the command prompt. The power light is very very dim, but doesn't look like it's flashing. I tried upgrading the firmware again with the GUI app and it still did it on the first time without a hitch. I will guess that the DD-WRT firmware is not getting loaded because of how quickly it gets "installed".

I think something got messed up with the vxworkskiller, but it's exhibiting the behavior of it as "the router can be pinged, but the web page cannot be browsed" so I think it's installed. Based on what I have said thus far, what would be the next recommended action. I was thinking trying to install the OEM firmware back on, but how do I do that, if I should? Thanks!

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.