Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Intel i3 350m and a Core 2 Quad 8300. The 350m is 2.2ghz, while the Core 2 Quad is 2.5ghz. With both, while looking at CPU-Z, they underclock themselves at seemingly random intervals (even while running games and stuff), then go back to their full speed. Why does it do this? Refer to core speed section below:

Cpu-z

share|improve this question
3  
"even while running games and stuff" - are these games optimised to use both cores? Otherwise it's perfectly reasonable for one of the cores to spin down. –  ta.speot.is Jun 19 '11 at 0:21
    
Ah, they likely are not. Just old Team Fortress 2, other source games. –  Simon Sheehan Jun 19 '11 at 0:22
1  
How are your temperatures during this? They could be downclocking to stay under a temp limit –  Phoshi Jun 19 '11 at 0:44
    
Temperatures are all within the normal range, not high. In the 30s and 40s usually. –  Simon Sheehan Jun 19 '11 at 0:50
4  
You almost have the question in its canonical form. You missed the one year anniversary of this question being asked and answered on SuperUser before, though. So too did this person. –  JdeBP Jun 19 '11 at 1:03

2 Answers 2

up vote 5 down vote accepted

This is the Enhanced Intel Speedstep Technology at work. You can read more about it on Intel's web site at http://www.intel.com/support/processors/sb/CS-028855.htm.

share|improve this answer
1  
The problem is that the system is downclocking even under load, as stated by the OP. –  DragonLord Jun 19 '11 at 3:01
1  
I would be quite surprised for the CPU load to be maxed out constantly, and whenever the load is reduced, Speedstep will kick in to reduce power and speed. Run a stress test program such as Prime95 (available from mersenne.org) on all cores and see if the speed continues to reduce. With Prime95 running on a single core, it will probably still fall back, but when run on all cores simultaneously, the CPU should stay maxed at 100% utilization. –  SteveM82 Jun 19 '11 at 4:48
    
One more thought ... you may be able to disable Speedstep in your motherboard's BIOS. If you can, that will help confirm whether Speedstep is the cause. –  SteveM82 Jun 19 '11 at 5:06

There's a setting in Windows Vista/7's Power control panel with something to the effect of "CPU Power Management" that might be affecting this as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.