Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Cygwin with rxvt, and I've tried mrxvt under X, as well as the default of bash in CMD. M-x doesn't work whilst other Meta combinations do. xev shows nothing for it (Meta shows, as you would expect from the fact that other combinations work). Rebinding it in .inputrc results in no action being taken. Spy++ shows MOD_ALT'X' being pressed. What else should I look at?

share|improve this question
    
I don't see a reason for this question to be downvoted. – bwDraco Jun 19 '11 at 23:26
    
Bizarre. Do I have to literally phrase as a question? – Sam Brightman Jun 20 '11 at 6:38
up vote 1 down vote accepted

I have Growl 2.0.6 running, and it appears to be capturing M-x. I decided to start killing running applications one by one, and Growl stopping got it working - I don't even need to restart Cygwin/emacs.

See, for example, the comment thread attached to the answer of question 1598854. There is a file in a location such as %LOCALAPPDATA%\Growl\2.0.0.0\user.config which has a setting:

    <setting name="KeyboardShortcutCloseLast" serializeAs="String">
        <value>Alt+X</value>
    </setting>

Once this is moved away from Alt-X (preferrably to something with more than one modifier or very uncommon), everything works as expected. It seems a change was made to the hotkey registration so that Growl can no longer pass the key on, and this hasn't yet been fixed.

share|improve this answer

Set the following Windows environmental variable:

CYGWIN=tty

and restart Cygwin.

share|improve this answer
    
I will try but a) I think it's already set; b) current documentation recommends having it off for "other terminals". More importantly, how does it explain only M-x not working? – Sam Brightman Jun 20 '11 at 6:37
    
I nearly accepted as logging in remotely showed tty not set and when I added it M-x worked. However, logging in again without setting it still worked. I still believe unset is correct for modern Unixy terminals. – Sam Brightman Jun 21 '11 at 6:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .