Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using curl to upload a file to ftp server. The same script is working on another system, but on this one after connecting to ftp it is not doing anything and connection times out. The detailed output with -v options is as follows:

curl -v -# -T live_mc.sql ftp://userid:pwd@myserver.dyndns.biz/rdirc/
* About to connect() to myserver.dyndns.biz port 21 (#0)
*   Trying xxx.xxx.xxx.xx... connected
* Connected to myserver.dyndns.biz ( port 21 (#0)
< 220-FileZilla Server version 0.9.37 beta
< 220-written by Tim Kosse (Tim.Kosse@gmx.de)
< 220 Please visit http://sourceforge.net/projects/filezilla/
> USER userid
< 331 Password required for userid
> PASS pwd
< 230 Logged on
< 257 "/" is current directory.
* Entry path is '/'
> CWD rdirc
< 250 CWD successful. "/rdirc" is current directory.
* Connect data stream passively
< 229 Entering Extended Passive Mode (|||3271|)
*   Trying xxx.xxx.xxx.xx...

I have also tried --upload-file, --user options but no success. Please help to figure out what is wrong.

share|improve this question

2 Answers 2

solved this with


option :D

share|improve this answer

Thanks, @TheVillageIdiot, for sharing this info. I have been researching a lot untill I found this "--no-epsv" method, so I wanna report to anyone interested that it makes CURL working from inside a virtual machine (I have tested it with Linux VM running inside a Windows 7 host), at least for sending files:

curl -u "myuser:mypassword" --upload-file MyFile.txt ftp://ftp.phpnet.us/htdocs/Test --no-epsv
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.