Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since the update gvim no longer displays a menu. The toolbar continues to work as expected.

I have tried :set guioptions-=m :set guioptions+=m

From within vim, and on advice from a similar problem have first removed ~/.gnome2/Vim (which did not help) then edited ~/.gnome2/Vim, changed

[Placement]
Dock=Toolbar\\0,1,0,0\\Menubar\\0,0,0,0

to

[Placement]
Dock=Toolbar\\0,1,0,0\\Menubar\\0,0,0,1

But neither of these things helps. Does anyone have any other ideas?

share|improve this question
    
However - it turns out that if I run gvim -f from the command line rather than gvim then all works and I have the expected menu. –  Rupert Jun 20 '11 at 12:02
    
The -f option only asks gvim to stay in the foreground (rather than detach from the console as gvim does normally). It should not make any difference but does fix the problem. –  Rupert Jun 20 '11 at 12:04
    
Same problem here .. I have the feeling that Unity is the culprit. –  h3. Jul 5 '11 at 3:32
    
Something new on this issue? –  Andrej Oct 9 '11 at 19:42

1 Answer 1

Try this in this order, it worked for me:

:set guioptions-=m

:set guioptions-=T

:set guioptions+=m

:set guioptions+=T

share|improve this answer
    
Note that the placement of the menu bar differ from other apps, which makes me think it is a problem with Unity.. I'm getting tired of this shit.. I think I'll check for another distro soon. –  h3. Jul 5 '11 at 3:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.