Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Randomly, I wasn't doing anything specific — my system starts getting sluggish. I check the activity viewer — wow, Finder is at 150% CPU!

This is what I have tried so far:

  • Trashing com.apple.finder.plist, com.apple.systemuiserver.plist and com.apple.loginwindow.plist
  • Trashing all apple.* namespaced .plist files
  • Turning off Calculate All Sizes in Finder
  • Turning off Show View Options in Finder
  • Disabling all startup items
  • Unplugging external hard drives
  • Getting rid of all data on desktop

However, if I create a new account or use my wife's account, the Finder CPU usage is normal.

I analyzed the Finder's CPU pattern, it goes like this: If active, it's always between 70 and 150% CPU usage. If i kill it, and stay 100% idle — it goes from 0-ish% to 100+% slowly, and the "Real Memory" column in Activity Monitor goes from 0MB to ~2GB+ slowly, and when it gets around there, it dies and cycles all over again.

What are some methods I can use to trace what's happening in Finder?

share|improve this question

migrated from stackoverflow.com Jun 20 '11 at 14:10

This question came from our site for professional and enthusiast programmers.

    
Try apple.stackexchange.com –  Paul R Jun 20 '11 at 13:58
    
Go in Console and see if anything's bothering Finder. –  Vervious Jul 12 '11 at 15:29
    
Random guess: you're trying to automount a volume that's no longer there. –  barrycarter Oct 22 '11 at 0:00
    
Are you using Time Machine? Were you connected to the Time Machine volume when finder went berzerk? –  Nathan Feb 14 '12 at 4:13

4 Answers 4

Try 'Repair Permissions' through Disk Utility. You can get more info from http://support.apple.com/kb/ht1452.

This had worked for me.

share|improve this answer

Go to Terminal, type iosnoop, and see what Finder is doing. You can also go to AM and click "Sample" to figure out what threads Finder has open.

share|improve this answer

Have you tried to start your Mac in Safe Boot mode? Hold Shift key immediately after startup sound, and release when you see the Apple logo. Does the problem occur then as well?

share|improve this answer

There are a few things to try, first check if you have anything in dashboard. Sometimes widgets can run away with your processor. Close widgets by holding down the option key and clicking the close circle that appears next to the widgets.

I'd also check console to see if there are any messages there about a process that's getting stuck. All messages (all logs) should show up anything that's repeatedly running over and over while you're logged in.

Finally try checking in the LaunchAgents folder in your home folder in the Library folder. Sometimes apps will install processes there that they want to start when you log in. If you subsequently delete an app the process in here may simply try and start something it can no longer find over and over. This often causes problems and slowdowns with no visible cause. This isn't the same as start up items in accounts so is often overlooked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.