Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ever since I installed Office 2010 I have to "unblock"(*) the documents/spreadsheets I download from Internet/mail. How can I change that so I don't have to do that anymore?

(*): right-click on the file -> properties -> Unblock

Note: I don't know if the button says exactly 'Unblock', I use spanish Microsoft Office so it says "Desbloquear" on my pc.

screenshot


Edit: I use Windows Vista Home Premium and Office 2010 Pro

share|improve this question
    
Not an answer, but: you know why it does this, don't you? Because it really helps to prevent malicious attacks by blocking the automatic opening and running of documents which may contain malicious macros. Doesn't stop you doing it anyway, but is at least one layer of security more than you had before. –  Rory Alsop Jun 22 '11 at 9:29
    
@Rory_Alsop I know why it does this. I just don't want it to do it; I know which dowloaded/emailed documents to open and which don't. I mean, I don't need that extra layer of security... my dad does, but I don't (and my dad doesn't touch my notebook) –  Toto Jun 28 '11 at 19:15

2 Answers 2

You do not say if you are using a Pro or home version, or what OS. This is not MS Office-related, but related to the Windows OS.

If you you have a Pro version, open gpedit.msc (this is not available in home version, but is easier to use) and go to:

User Configuration>Administrative Templates>Windows Components>Attachment Manager and enable the policy called "Do not preserve zone information in file attachments".

If you have home, go to this registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments

and edit the value for key "SaveZoneInformation" to 2 .

http://support.microsoft.com/kb/883260

share|improve this answer
    
I don't have an Attachments key under HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\. I do have HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Attachment‌​s key, but it doesn't have a SaveZoneInformation value. –  Toto Jun 21 '11 at 14:02
1  
@Toto You can add it system wide under the HKLM area, or make it just specific to you, and add the Attachments key under HKLU. In either case, in the right pane, right-click and add a 32-bit DWORD value and name it SaveZoneInformation (this is case sensitive, so cut and paste it). Then set the value to 2. –  KCotreau Jun 21 '11 at 14:23

This is not directly due to Microsoft Office, but is due to a new security setting in Windows which may have been installed as a kb patch during the install of Office. By default now, when Windows downloads files from an "untrusted" source, it blocks those files on your local computer. It can be a real pain, especially for zip archives.

share|improve this answer
    
Thanks @BBlake. Can I change that setting somewhere in Windows then? –  Toto Jun 21 '11 at 13:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.