Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
  1. I can see other people in my homegroup and their folders, but when I click on those folders, I cannot see the contents (no error message, just nothing happens).
  2. The other people in the Homegroup can see me just fine, and my files
  3. In addition, I am unable to access any network computers, even my own.

In addition, I cannot see the files that they have under the network tab, though they can all see each others stuff.

What could be the issue?

The homegroup has already be created and recreated numerous times.

Perhaps unrelated, but I am unable to turn off password protected sharing.

EDIT: The error that I get is the network provider name is invalid.

share|improve this question
up vote 1 down vote accepted

Verify that the Microsoft Client for Microsoft Networks is installed on your adapter.

If this client is not installed, you can install it using the following steps: Click Add. Click Client, and then click Add. Click Microsoft, click Client For Microsoft Networks, and then click OK. Click OK. When you are prompted to restart your computer, do so.

share|improve this answer
Click add where? – soandos Jul 11 '11 at 21:19
Right-click a local area connection, and then click Properties. Click Install. In the Select Network Feature Type dialog box, do one of the following: To install a client, click Client, and then click Add. In the dialog box that appears, select the item that you want to add, and then click OK. – wizlog Jul 11 '11 at 21:24

Edit: Try disabling the Guest Account, or removing it's password. There appears to be a permissions conflict if the Guest Account is enabled and PW protected.

I had a similar issue when using a Windows 7 copy that turned out to be fake. My issues started when MS started viewing the product key as deactivated. They eventually gave me a new product key, because it was purchased from a "legit" dealer, who was selling copies with his own enterprise key, and charging retail prices.

It's unlikely that you have the same activation issue I did, but the Network settings described below are a likely culprit.

Long story short, the Homegroup functions are somehow tied to activation, so if you run the MS Genuine Software verification program, and it says it can't activate, it could be related there.

As in your case, everything else worked for me, but the Homegroup and sharing functions never did. You should also check if your network is set on Public. That will cause the same issues, and if you have the same issue I did, you will not be able to change it to Home or Work settings. Public network setting also invalidates the no password sharing, and Homegroup functions.

You can change the Network location as follows:

To change a network location type

If your computer is part of a domain, you won't be able to change the network location type because it is controlled by your network administrator.

Log on to the network.

Open Network and Sharing Center by clicking the Start button , clicking Control Panel, clicking Network and Internet, and then clicking Network and Sharing Center.

Click Customize, and then click either Public (for "Public place" networks) or Private (for "Home" or "Work" networks). If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Click Next, and then click Close.


Choosing "Private" permanently changes the firewall configuration to allow communication. This can be a security risk.

share|improve this answer
I am not part of a domain, and my network location is set up as Home. My OS is genuine (just reran validation). – soandos Jul 3 '11 at 6:33
Ok. Different issues, it appears. What firewall/Antivirus package are you running? Do you have a guest account on your PC? If so is PW protected? – zenbike Jul 3 '11 at 6:42
Yes I do, yes it is, just standard MSE and windows firewall running – soandos Jul 3 '11 at 7:09
See the edit at the top of my answer. – zenbike Jul 3 '11 at 7:12
Done (disabled, dont know how to remove the password). Did not help. – soandos Jul 3 '11 at 7:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .