Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 (64-bit) virtual machine that I primarily remote desktop into. Sometimes on boot something goes wrong and it displays the following DOS screen:

                             Windows Error Recovery
Windows Failed to start. A recent hardware of software change might be the cause.

If Windows files have been damaged or configured incorrectly, Startup Repair can help diagnose and fix the problem. If power was interrupted during startup, choose Start Windows Normally.
(Use the arrow keys to highlight your choice.)

 * Launch Startup Repair (recommended)
 * Start Windows Normally

The default option is Launch Startup Repair (which happens automatically after 30 seconds). How can I set it so that this never happens, and it always tries to Start Windows Normally?

share|improve this question
add comment

3 Answers

up vote 12 down vote accepted

Do this command:

bcdedit /set {current} bootstatuspolicy ignoreallfailures

Similar is

bcdedit /set {default} bootstatuspolicy ignoreallfailures

They can be the same if you are booted into the default load, so default would equal current.

For more information, the relevant Google search is "disable Windows Error Recovery" (minus the quotes).

share|improve this answer
add comment

A better solution would be to implement the following line for the BCDedit.

bcdedit /set {default} bootstatuspolicy ignoreshutdownfailures 

This way, only shutdown failures will be ignored and the system won't go in to recovery mode. Recovery mode will still be available when the machine fails to boot properly and encounters other errors.

share|improve this answer
add comment

I also saw this:

At the Command prompt enter the following:

bcdedit /set {default} recoveryenabled No

This will disable Startup Repair from automatically booting when there is a problem.

However, BEWARE.....

You'll have to get back into Windows as and Admin to re-enable it... just change the No to Yes.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.