Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got two systems that are right next to each other, and connected wirelessly to the same router. I want to connect the two of them together with an ethernet cable - both have gig-e and autonegotiation so it should work. I DON'T need the second system to have internet, but I need any specific tweaks to be on that system only.

I do not need to share internet. I need RDP to work, and thats it

The wireless runs on a 192.168.1.x subnet and ICS always runs on a 192.168.0.x subnet so that wouldn't be a problem.

Ideally I want this layout. Can I do this with ICS, or there some other free or open source way?

     +---------------------------+           +-----------------------------+
     | Laptop 1                  |           | Laptop 2                    |
     | Client- mobile            |           | 'server'- stationary system |
     |                           <-----+----->                             |
     | RDP client                |           | RDP Server                  |
     | MUST have wireless access |  ethernet | Runs ICS or similar         |
     +---------+-----------------+           | wireless access optional    |
               |                             +-----------------------------+
               |
               |
               |
               |
               |
               |
               |
               +---------------+     wireless to internet
share|improve this question
1  
I like the diagram. –  KCotreau Jun 21 '11 at 2:16
3  
Thanks. I used a webapp called ASCIIflow to do it ;) –  Journeyman Geek Jun 21 '11 at 2:29
    
@Journeyman Geek Thanks for the info. Of course, I realized that switches started using the uplink (sometimes on all ports) a long time ago. I did not realize that NICs also had that now. I think I mis-read what you were trying to do, so I will delete my answer and re-think it. –  KCotreau Jun 21 '11 at 2:45
    
i worked most of it out, eventually. It was oddly simple ;p –  Journeyman Geek Jun 21 '11 at 2:51
    
@Journeyman Geek "It was oddly simple", that was the reason I thought maybe it was a crossover cable. That could really trip someone up. –  KCotreau Jun 21 '11 at 2:55

2 Answers 2

up vote 6 down vote accepted

Apparently, assuming one of your systems supports autonegotiation the following process will work

  1. connect both the systems with an ethernet cable - a plain vanilla one will work with autonegotiation, else you'll need a crossover. Most modern systems support it.

  2. You'll need to set up both systems with static IP addresses, ideally from one of the 3 private blocks. Since most home networking uses the class C block, i chose to use the class A block, using the subnet mask 255.0.0 from here.

Currently i don't know what is the proper default gateway to use for the 'server', so as far as the systems are concerned, its a private network - so any sharing will need the ports explicitly opened in the firewall. I need to work out how to fix this.

In order to set up static IP addresses

go to Control Panel\Network and Internet\Network and Sharing Center

select change adaptor settings

enter image description here

select the Local Area Connection/ethernet connection (it seems to vary between windows 7 and 8)

select properties

enter image description here

Select Internet Protocol Version 4 and hit properties

enter image description here

I use these settings for the 'server'

enter image description here

for the 'client'

enter image description here

You can set the connection type as anything on the 'client' - it will be stuck as 'public' on the server.

  1. you can test this with ping
share|improve this answer
1  
You don't need a gateway. That is only to route traffic on those NICs to a different network. You are not doing that since you use a totally separate NIC with a gateway to get to the Internet. For RDP, open 3389. –  KCotreau Jun 21 '11 at 2:50
    
windows 7 assumes any network without a gateway is insecure, amusingly. I cannot change the connectiont type on the 'server' system to anything else. –  Journeyman Geek Jun 21 '11 at 2:52

I have these settings on the two computers connected with a single RJ45 cable, and it worked:

PC-1 (windows 8):
    IP: 192.168.200.1
    Mask: 255.255.255.0
    Gateway: 192.168.200.1
    DNS Server: <leave blank>

PC-2 (windows 7):
    IP: 192.168.200.2
    Mask: 255.255.255.0
    Gateway: 192.168.200.1
    DNS Server: <leave blank>

I had to set the gateway, otherwise it's not working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.