Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to mount a samba share in ubuntu, however I can't seem to make it read/write for other users (I can read write to it fine).

This is the fstab entry:

//10.0.0.1/storage/dumps /media/dumps cifs _netdev,guest,uid=1000,gid=1001,iocharset=utf8,fmask=777,dmask=777,file_mode=0666,dir_mode=0777,umask=000,rw,user,exec,codepage=unicode,unicode 0 0

where gid=1001 is the smb share group (I created) and uid=1000 is me. Any ideas?

share|improve this question
add comment

1 Answer

  • Put your credentials in fstab, using the credentials=/path/to/credfile mount option. The file must contain your username and password in two separate lines. All users will connect as the same SMB account.

  • True multi-user mounts can be done with the multiuser option; however, this requires Kerberos security to be used (sec=krb5i, krb5p, krb5), since the kernel cannot prompt users for credentials.

    (It may be possible to use PAM and kernel keyrings to store the password on login, but so far this is just an idea, and it would be more complicated and less convenient than Kerberos.)

share|improve this answer
    
Im connecting as guest so login shouldnt be needed –  user226 Jun 22 '11 at 2:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.