Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I always have my master channel muted, and I switched the volume applet to adjust the headphone channel. This way, sound never comes out of my speakers, but it's always on when I plug headphones in.

However, when I use my Fn keys to adjust volume, they adjust the "master" channel, rather than the "headphone" channel. How do I change this behavior? If it makes a difference, I am using a Dell Inspiron 1200.

Related question for solving this problem in Karmic

share|improve this question
    
Related question for solving this problem in Karmic: superuser.com/questions/51842 –  Matthew Oct 20 '09 at 16:56
add comment

1 Answer

up vote 4 down vote accepted

This is specified by the System > Preferences > Sound menu option. Select the channel you want to control under the Default Mixer Tracks section.

Sound Preferences

share|improve this answer
    
This worked. To get any options another than "Master" in the list, I had to switch "Device" from the PulseAudio mixer to the Alsa Mixer. Does this mean that I am no longer using PulseAudio? Any side-effects I should know about? –  Matthew Aug 26 '09 at 13:58
    
I have an Apple keyboard, which also have similar keys, but i guess are having some different codes. How can I get the actual codes from my new keyboard, and how do I map those into the mixer ? –  jfmessier Oct 20 '09 at 18:09
    
@jfmessier: Check answer from mas to this question superuser.com/questions/2194/remap-keys-in-linux –  nagul Oct 20 '09 at 20:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.