Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The title says it all: I am trying desperately to keep OCS from starting automatically when I log in to Windows. The first and only thing I did was unchecking the "Automatically start Communicator when I log on to Windows" option. I can verify that it is still disabled, but OCS ignores that and starts up as soon as I log on to Windows.

There is no OCS in the "Startup" folder, and the registry setting "AutoRunWhenLogonToWindows" at HKEY_CURRENT_USER\Software\Microsoft\Communicator is set to 0x00000000.

I am using Office Communicator 2007 R2 on a Windows 7 with Microsoft Office 2010.

Unfortunately none of the two answers I got so far didn't work: * Changing the said key in the Default User\NTUSER.DAT file instead => No effect. * Turn off the "Display status" option in MS Outlook => No effect.

share|improve this question
    
Do you, by any chance, have Outlook configured with an Exchange account? –  TFM Jun 21 '11 at 6:58
    
@TFM: Yes, I do. –  chiccodoro Jun 23 '11 at 6:57

3 Answers 3

There are a few configuration changes that I make on computers that need to be set in the Windows registry.

With having over 600 computers that I oversee, making sure certain settings are configured are needed. Our System Admins do a good job at configuring most things - but there are other changes that I like to take on myself.

One of those configuration items that I change in the registry is to disable the automatic loading of Microsoft Office Communicator when new users login. In many circumstances, the program is not used - and should not be used - by the majority of our staff. So when a new user logs into a computer, we do not want Microsoft Office Communicator automatically starting.

To remove the automatic loading of Office Communicator when new users sign into a Windows computer, you'll need to make a change in the registry. This setting is stored in the ntuser.dat file in the C:\Documents and Settings\Default User folder.

So to disable Microsoft Office Communicator from loading in the registry, open up the Registry program (regedit.exe). Click the HKEY_USERS key and then to up to File and choose "Load Hive".

You will then browse to the C:\Documents and Settings\Default User\NTUser.DAT file. Open this file and it will ask you to name it. Simply enter 'ntuser'.

Now, you have loaded the default user registry hive so you can make the change needed. Go here in the registry:

HKEY_USERS\ntuser\Software\Microsoft

Now you need to create a new folder here - so right-click in Microsoft, choose New and then Key. You will name this key "Communicator".

After the folder has been made, ensure you have the Communicator folder selected. Now, you need to create a new REG_DWORD entry.

Right-click in the white pane on the right-side and click New - DWORD Value. The name of the key needs to be "AutoRunWhenLogoonToWindows".

Now, give this key a value of "0" to disable Microsoft Office Communicator from automatically starting up upon login. If you want it enabled, set the setting to "1".

SOURCE

share|improve this answer
    
I don't think that you really got the point. The very key hidden in the middle of the very lengthy quote is the one I already said had no effect. Anyways I tried and also changed that key for the default user, without any success. –  chiccodoro Jun 23 '11 at 12:33
    
I did realise it repeated that, but im also aware that there were other points you hadn't tried –  admintech Jun 23 '11 at 13:06

There are some options in Outlook that's makes use of Office Communicator, one of them is the "Display online status next to name" under the "Contacts" settings:

Display online status next to name

Checking that box would start Office Communicator anyway, because Outlook cannot handle the function on its own. (I don't know why the box is greyed out on my PC, but it may be because I don't have Communicator installed at home).

More information: Use instant messaging services with Outlook

share|improve this answer
    
Hi TFM. That is a very intersting hint. Unfortunately, after disabling this option and logging out and in again, it still starts up... –  chiccodoro Jun 23 '11 at 12:34

Try running msconfig, then go to Startup and disable Office Communicator.

I bet this works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.