Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Windows 7 RTM, and things are running smoothly for the most part. My Windows 7 installation is the default, out of the box configuration.

I am using the standard TFTP utility available with Windows 7. When I attempt to upload a 3 kb text file to our internal TFTP server, it always time's out. However, TFTP'ing the same file, on XP (from the same network port --- different laptop, but same model) it works perfectly.

Is anyone aware of any default configuration on Windows 7 (or even) Vista that could cause this?

share|improve this question

There is a warning at the DD-WRT TFTP-Flash page that might be useful.

Recommendations - In order to catch the narrow window for TFTP flash, you should use platforms with simple TCP/IP implementations that don't have CTCP implemented: WinXP or Linux are reported to work, but some are reporting significant problems with Vista, Windows 7 or Windows 2008.

Can you consider using the FTP client?
you would need a FTP server rather than a TFTP server at the other end.

According the the Wikipedia page, the following is supposed to disable CTCP,

netsh interface tcp set global congestionprovider=none

However, what I fail to understand is -- TFTP uses UDP rather than TCP,
So, I don't get how the CTCP problem is related to TFTP.

share|improve this answer
up vote 0 down vote accepted

It seems that the issue may be with the network card driver. I'll wait until an official Windows 7 driver is released for my Broadcom NetXtreme Gigabit NIC.

share|improve this answer
Turned out it was my 3rd party firewall disabling this traffic. Kind of a dumb mistake on my part, but I wanted to post the root cause here in case someone runs into the same problem/oversight. – Mick Dec 6 '09 at 18:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.