Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ever since FireFox 4, page tabs have been moved to the top of the window. This gets pretty irritating when surfing the net through a remote desktop session. Often when I want to switch tabs, if I accidentally move my mouse a little to much to the top, I get the remote desktop connection bar blocking the tabs instead, then I'd have to wait a few frustrating seconds before it disappears again.

So, are there any methods to shrink or shorten the remote desktop connection bar or delay the appearance of it?

share|improve this question

10 Answers 10

Uncheck the Display the connection bar when I use the full screen to get rid of the bar. You can then use Ctrl+Alt+Break to switch between local/remote sessions.

Remote Desktop Connection Option

share|improve this answer
    
I tried that option before, but if I needed to switch back to the local machine, I am forced to break the connection since the minimization button is now gone, and win+D works only on the remote machine, and then re-connect to the remote machine. It's still a bad user experience. –  Some Noob Student Jun 21 '11 at 13:35
    
@Sheldon: I thought about that also, but afaik, that is the only way to remove the bar. You could, as @Joel said, move it out of the way. But that only goes left and right horizontally. You can't put it vertically. –  paradd0x Jun 21 '11 at 13:38

This is a bit unorthodox, but it works for me. I only occasionally switch between sessions throughout the day. If you're switching frequently, this might be more of a nuisance than helpful, admittedly.

Uncheck the "Display Connection Bar" as noted above. To switch between, pressing Ctl+Alt+Del brings up Task Manager for the Local computer. At the same time, you may notice that the Taskbar/Start Menu switches to the local machine as well.

This allows you to click on a Taskbar button to bring up a locally-running application. When you want to switch back to the remote session, the Taskbar button for RDP should still be running - just click over.

I'm using XP SP3 on both machines. I hope this works elsewhere for you, too.

share|improve this answer
    
Nice workaround, thank you for sharing your experiences! –  Some Noob Student Mar 2 '12 at 19:48
    
this was useful, thanks –  Alex Jul 22 '12 at 12:14
    
Also, if you want to open task manager on remote machine, Ctrl+Shift+Esc works for me (Win7->Win7). Then again, I'm rocking dual monitors like a boss, so there's no need for your full-screen Ctrl+Alt+Del tom-foolery. –  Ross Aiken Dec 13 '13 at 18:14

I tried to edit paradd0x's answer above to include the idea of using Ctrl+Alt+Home as that more exactly answers the question, but it was rejected by the mods. Kind of annoying, but whatever.

So what I think is the easiest thing to do here is to:

  1. Uncheck Display the connection bar when I use the full screen as already mentioned, which prevents the connection bar from popping out on you when you mouse to the top of the screen
  2. And then when you want to see the connection bar press Ctrl+Alt+Home which is precisely the key combination assigned to making it show

This keeps the connection bar out of the way until you specifically summon it. And once you've summoned it, simply clicking anywhere else will make it go away completely until you summon it again.

This seems to be exactly what you're wanting, no? I use this myself (in conjunction with the below).


An alternative to consider:

I use Chrome, which has the same "problem" with the tabs. I'm also a long-time Winamp user and use it in Windowshade mode at the top of my screen, with Always on top set to true. When Chrome isn't maximized it leaves just enough room for Winamp to hover above the tops of the tabs. This combined with the fact that maximizing any web browser on a 24" monitor (all my monitors are 24") is a waste of horizontal space, means that I literally never maximize Chrome.

As an aside, I use WinSplit Revolution which is a (free) utility that places/sizes the focused program wherever you want. For instance, pressing Ctrl+Alt+Numpad5 will position Chrome (or whatever's focused) in the center of the screen at 66% width and 100% height, which is my preferred browser size on a 24" monitor. Additional presses of the same keys cycle through different placements/sizing, one of which is 100% width, 100% height, but not maximized -- this would allow you to use your browser "full screen" if that's how you prefer, but still have the tabs pushed down away from the top of the screen. WinSplit is the single most used/useful utility I've found in my 15 years of working with computers.

Anyway... where this applies to Remote Desktop is Winamp will actually show over the top of even a full screen Remote Desktop session. When I want to switch back to my local machine, I simply click Winamp once and the taskbar from my local machine appears -- voilà!. I mainly RDP into my workstation, so I prefer not to minimize the remote session. Running local programs at less-than-full screen width leaves portions of the remote session visible in the background (not to mention completely visible on my second monitor) allowing me to keep tabs on incoming email, new IMs that pop up, etc. I'm so used to the convenience of this that I run Winamp even when I don't have it playing any music.

share|improve this answer
1  
On the other hand, having your answer rejected made you post a great answer that goes through several alternate ways of doing what the OP needed. Edits should never add new information, it should, ideally simply refine a current answer. I'd consider this mission accomplished, as far as edit rules go. –  Journeyman Geek Apr 30 '13 at 8:27
    
Yeah, I suppose you're right about edits not adding new information. I think it is fine to add new info when editing my own answer(s). But it makes sense not to add new info to someone else's answer. I hadn't thought about the difference there, I guess. –  sliderhouserules Apr 30 '13 at 9:28
    
For me, Ctrl+Alt+Home doesn't do anything. –  oberlies Nov 26 '13 at 12:28
    
You have to be in full-screen mode and have unchecked the option to "Display the connection bar when I use the full screen". Then Ctrl+Alt+Home is the hotkey combination to make the connection bar show. The only way for it to not "do anything" for you is if you're doing it wrong. Sorry. I use this functionality almost every single day. –  sliderhouserules Dec 10 '13 at 3:25

If you don't mind the change in functionality while in the remote session, you can change the selection under Keyboard in Local Resources tab in the options for RDC.

By choosing "On this computer" rather than "Only when using the full screen", you can switch back to the local computer, or to another session, using Alt-Tab. Also, pressing the window key on the keyboard will bring up the start menu and taskbar of the local computer, if needed.

I also disabled the "Display Connection Bar" option as noted in other answers.

Note: I am using Win7 Ultimate. I do not know if there are differences with other clients.

share|improve this answer
    
Really only an option if you would otherwise never use Alt+Tab to switch between programs. Not having Alt+Tab on the remote computer would cripple most of my workflows. –  oberlies Nov 26 '13 at 12:31

And don't forget, in firefox the tabs can be placed below the toolbars.

Here is how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste tabs and pause while the list is filtered

(3) Double-click browser.tabs.onTop to switch it from true to false to move the tabs below the toolbars.

Source: http://support.mozilla.org/en-US/questions/925973

share|improve this answer

You can drag it over to one side or the other to move it out of your way.

share|improve this answer
2  
If you have a 22" monitor and 3 page tabs this would do. But this is not enough for me, I need the bar shortened for good, or moved vertically to the right or left side of the screen. –  Some Noob Student Jun 21 '11 at 13:21
3  
"You can turn the handle to open the door." would not be an answer to "How can I get my door unjammed?". -1 –  Amicable Jun 25 '12 at 9:22

How about switching the RDP Session to Full Windows Mode using Shortcut - Control + Alt+ break minimizing to client window and switching it back to full mode if needed...

Remote Desktop Shortcuts to look for which may get your work done much easier

share|improve this answer

MY SOLUTION:

You can:

"Uncheck the 'Display the connection bar when I use the full screen' to get rid of the bar", as others have stated.

Then while in the RDP settings, go to the next tab over titled: "Local Resources", and change the option for: "Apply Windows key combinations" change that to 'On this computer' which will make Alt-Tab toggle back on the local PC, not the remote PC.

CTRL commands still work on remote PC like CTRL-C, CTRL-V, etc...

Then ALT-TAB now gets you back and forth...

share|improve this answer
1  
BTW, since both of my desktops look the same (same icons, same theme and wallpaper, etc), I use the freeware program Classic Shell and change the start button to the slightly different one so I can quickly tell which desktop I am on. –  Samsonite801 Oct 2 '13 at 20:48

Or just 'Unpin the connection bar' by hovering over the pushpin shown on left. Then, the connection bar shows up only if you hit screen top by your cursor, when in the RDP.

You still can accidently hit it while navigating tabs in browser. But it is a visual display and you can back out right away.

Lastly, the pushpin always stays unpinned - whether you have pinned or unpinned the connection bar. So hover over it to see current status.

share|improve this answer
    
The OP clearly already does have it unpinned. –  HopelessN00b Jul 23 at 18:51

Just click the 'pin' icon in the connection bar. It'll be hidden most of the time and will only show when your mouse cursor is at the very top of the screen.

You can also drag the connection bar left and right.

share|improve this answer
    
OP already does that, and is annoyed that the bar is easy to trigger accidentally when using the mouse near the top screen edge. –  sleske Apr 5 '13 at 15:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.