Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just installed ubunto in Vmware Player and it works great, but all of the resolutions it gives me there isn't one to fill the entire screen.

I was scouting around the net and found this,

- Open up VMWare, don't boot up Windows yet.
- Go to "View" and select "Autofit window" and "Autofit Guest".
- Close VMWare.
- Go to the terminal and do:
sudo gedit ~/vmware/preferences
- Now where it says:
pref.autoFitFullScreen = "fitHostToGuest"
change it to:
pref.autoFitFullScreen = "fitGuestToHost"

but when i do it the preferences file is empty

Can anyone tell me where it is??

Totally lost

edit

I have installed VMtools...

share|improve this question

3 Answers 3

up vote 5 down vote accepted

The preference file is located on your host computer NOT in your VM!

Location on a Windows host:

C:\Users\<username>\AppData\Roaming\VMware\preferences.ini

Location on a Linux host:

~/vmware/preferences/preferences
share|improve this answer

You need to install VMWare tools in order for your VM to make use of your screen resolution.

Follow this guide/tutorial in order to install it on vmware player.

share|improve this answer
    
Guide is ancient! –  mlissner Aug 21 '13 at 2:22
1  
@mlissner well it would be ancient due to the time the question was answered. –  Sandeep Bansal Aug 21 '13 at 19:17

I tested that, when Windows is guest OS, but may work with other OS too: enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.